Networking settings in ESXi host is blank in the vSphere Client
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Networking settings in ESXi host is blank in the vSphere Client

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Article ID: 324510

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides steps to update the memStopInMB to the updated memory limit in vCenter Server.


Symptoms:
  • Network settings are not visible for some ESXi hosts.
  • vMotion to the affected host fails.
  • In the vpxd.log file, you see entries similar to:
     
    <YYYY-MM-DD>T<time> warning vpxd[09628] [Originator@6876 sub=InvtHostCnx opID=HostSync-host-83318-2cdad722] [VpxdInvtHost::FixNotRespondingHost] Returning false since host is already fixed! </time>
    <YYYY-MM-DD>T<time> warning vpxd[09628] [Originator@6876 sub=InvtHostCnx opID=HostSync-host-83318-2cdad722] [VpxdInvtHostSyncHostLRO] Failed to fix not responding host host-83318 </time>
    <YYYY-MM-DD>T<time> warning vpxd[09628] [Originator@6876 sub=InvtHostCnx opID=HostSync-host-83318-2cdad722] [VpxdInvtHostSyncHostLRO] Connection not alive for host host-83318 </time>
    <YYYY-MM-DD>T<time> error vpxd[09628] [Originator@6876 sub=InvtHostCnx opID=HostSync-host-83318-2cdad722] [VpxdInvtHostSyncHostLRO] FixNotRespondingHost failed for host host-83318, marking host as notResponding </time>
    <YYYY-MM-DD>T<time> warning vpxd[09628] [Originator@6876 sub=VpxProfiler opID=HostSync-host-83318-2cdad722] InvtHostSyncLRO::StartWork [HostSyncTime] took 70001 ms </time>
    <YYYY-MM-DD>T<time> info vpxd[09716] [Originator@6876 sub=vpxLro opID=154794cb] [VpxLRO] -- BEGIN task-internal-5411444 -- host-83318 -- vim.HostSystem.acquireCimServicesTicket -- 52eedde2-380c-533d-f161-7f5a84c62022(52dab84b-6287-c2dd-4c44-ebac6ad088a7) </time>
    <YYYY-MM-DD>T<time> info vpxd[09856] [Originator@6876 sub=vpxLro opID=HB-SpecSync-host-83318@0-6d4884dc] [VpxLRO] -- BEGIN task-internal-5463227 -- host-83318 -- SpecSyncLRO.Synchronize -- </time>
    <YYYY-MM-DD>T<time> info vpxd[05852] [Originator@6876 sub=vpxLro opID=4016bd26] [VpxLRO] -- FINISH task-internal-5463224 </time>

    Note: This log excerpt is an example. Date, time, and environmental variables may vary depending on your environment.
     
 


Environment

VMware vCenter Server 6.0.x

Cause

Due to the smaller cache size, the host config is not available upon request in the cache requires to make a RPC call which evicts some other host-config object(or other objects) when the config is received from the host, causing the cache to thrash.

Resolution

This issue is resolved in VMware vCenter Server 6.0 Update 3, available at VMware Downloads. If you are running 6.0U3 or higher, please refer to Networks not appearing on ESXi host for more details on your situation.

To work around this issue when unable to upgrade to 6.0U3 or higher, update the memStopInMB to the updated memory limit in vCenter Server.
 
To determine the new value for memStopInMB:
 
  1. Open a Windows command prompt.
  2. Navigate to C:\Program Files\VMware\vCenter Server\visl-integration\usr\sbin with this command:

    cd C:\Program Files\VMware\vCenter Server\visl-integration\usr\sbin
     
  3. Run this command to determine the correct value for memStopInMB:

    .\cloudvm-ram-size.bat vpxd
 
Adjusting the memStopInMB parameter in vCenter Server:
  1. Connect to vCenter Server using the vSphere Client and administrator credentials.
  2. Select Administration > vCenter Server Settings.
  3. Select Advanced Settings.
  4. Select Edit...
  5. Change the value of the config.vpxd.memChecker.memStopInMB key to the number returned by the cloudvm-ram-size utility.
  6. Click OK.
  7. Restart the vCenter Server services.