The resource 'Port-ID' is in use error when removing a host from VDS
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The resource 'Port-ID' is in use error when removing a host from VDS

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Article ID: 324497

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When an ESXi host has no running virtual machines and is on Maintenance Mode, you experience these symptoms:
  • You cannot remove an ESXi host from the vSphere Distributed Switch (vDS).
  • You see the error similar to:

    The resource '###' is in use. 

    Note: In this example, ### is the port-ID in use at that time. This could be any value.


Cause

In this situation, typically the vCenter database will contain a record that suggests that a dvPort with the number of '###' in "in use".  This is why vCenter is issuing that error message. 

However, when you look at the output from the command "esxcfg-vswitch -l" on the ESXi host, the "in use" associated with that dvPort "###" may contain "0" (which means it is not in use). 

The dvPort "###" could be associated with a vmkernel interface.  The vmkernel interface could be one associated with Management, vMotion, VSAN or other services. 

Also, the dvPort "###" could be associated with a virtual machine that has a snapshot that has not been consolidated.  

Also, the dvPort "###" could be associated with a virtual machine template.  

Resolution

The best way to remedy this, will depend on which type of network connection is associated with the dvPort "###" in the error message.

If you determine that:

  1. The dvPort "###" is associated with a virtual machine or a virtual machine template, and
  2. The Management vmkernel interface configured for the host is configured to use a standard switch (or a different vDS than the one in question);

Then you can follow the procedure below:

  1. Place the ESXi host in Maintenance Mode  (NOTE:  If the ESXi host is part of a VSAN cluster, make sure that you select the appropriate Maintenance Mode option that is suitable for a host to completely leave the VSAN cluster, as if it were being decommissioned. )
  2. Disconnect the ESXi host from vCenter:  vSphere client --> vCenter --> Hosts and Clusters icon --> Right click on the ESXi host --> Connection --> Disconnect
  3. Once successfully disconnected, remove the ESXi host from vCenter (which will also remove the ESXi host from any vDS of which it is a member):  vSphere client --> vCenter --> Hosts and Clusters icon --> Right click on the ESXi host --> Remove from inventory

In all other cases, we would suggest that you open a Support Case by following the process in Creating and managing Broadcom support cases.