Multiple Applications show 0 members after upgrade to vRealize Network Insight version 6.2.0 and 6.3.0
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Multiple Applications show 0 members after upgrade to vRealize Network Insight version 6.2.0 and 6.3.0

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Article ID: 324462

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Updated On:

Products

VMware Aria Operations for Networks

Issue/Introduction

Prevention/mitigation on Application migration issue in vRealize Network Insight version 6.2.0 and 6.3.0

Symptoms:
  • Post upgrade when the customer edited the application the member type and member criteria are missing for the applications.
  • This issue is seen for Only manually created applications and not Service Now apps or Flow-based.
  • The issue is seen with the Applications with VM which have spaces in the name  


Environment

VMware vRealize Network Insight 6.3.x
VMware vRealize Network Insight 6.2.x
VMware vRealize Network Insight 6.x

Cause

The RCA of the issue revealed that while migrating applications, we were removing some of the VMs containing spaces in their names.
Setups where the VM names typically contain spaces, migration all such applications show 0 members.
However, it might so happen that all affected applications will not show 0 members of any of the VM doesn't contain spaces in its name. 

Resolution

A vRealize Network Insight future version (6.4.0) has the fix for this issue.


Workaround:
Prevention steps in vRealize Network Insight version 6.0.0 and 6.1.0

The below steps should be done only once while upgrading to vRNI version 6.2.0 or 6.3.0.
Please use the below table to find out the scenario when these steps need to be performed

 
Current vRNI VersionTarget upgrade VersionSteps to be performed
vRNI 6.0.0vRNI 6.1.0No
vRNI 6.0.0vRNI 6.2.0 (skip upgrade)Yes
vRNI 6.1.0vRNI 6.2.0Yes
vRNI 6.1.0vRNI 6.3.0 (skip upgrade)Yes
vRNI 6.2.0vRNI 6.3.0No

1. Query to check if a customer might face the issue if they upgrade to version 6.2.0 or 6.3.0. This query can be run from GUI of vRNI
  a) vm where application is set and name like ' ' group by application

2. If the above query gives any output application, there is a possibility of data corruption after upgrade to 6.2 or 6.3. 

Follow the steps mentioned below. If there is no output, then no steps need to be done.

 a) With version 6.0.0 or 6.1.0 release, login to the platform1 using SSH. In the case of a stand-alone platform, login into that platform VM
 b) Download the jar file with file name
tools-0.001-SNAPSHOT.jar ( See the section Files on this Knowledge Base Article on the right-hand side)
 c) Copy the jar file to platform VM
     scp tools-0.001-SNAPSHOT.jar support@<platform1IP/hostname>:/tmp/
 d) Take SSH (putty session) on the platform1 machine using support user.
     ssh support@<platform1IP/hostname>
 e) Change to the user from support to Ubuntu using the command below
      sudo su ubuntu
 f)  Change permission of the file on the platform VM
     sudo chown ubuntu.ubuntu /tmp/tools-0.001-SNAPSHOT.jar
 g)  Copy the jar file to the /home/ubuntu/ directory
  sudo cp /tmp/tools-0.001-SNAPSHOT.jar /home/ubuntu/

 h)  Run the jar using the below command to take a backup of the applications.
    
java -Dpolicy.config.path=/home/ubuntu/build-target/server-utils/policy/ -Ddlf.path=dir:///home/ubuntu/build-target/deployment/dlf -Dtsdb_client.configuration=/home/ubuntu/build-target/restapilayer/tsdb_client.configuration -Dtimeout=30 -Xmx2048M -cp tools-0.001-SNAPSHOT.jar  com.vnera.tools.BackupApplications -m backup

 i) Check if the backup folder is created using the command
 
 ls -larth /var/lib/ubuntu/application_backup/

 j) Exit the terminal using the command. Run this command twice.
    exit

3. Upgrade the vRealize Network Insight setup to version 6.2.0 or 6.3.0 release as required.

4.  After the upgrade to version vRealize Network Insight 6.2.0 or 6.3.0  is successful, run the below commands.

Note: Please don't do any activity on the UI while restoring the applications. 

a) Take SSH (putty session) on the platform1 machine using support user. In the case of a stand-alone platform, login into that platform.

  ssh support@<platform1IP/hostname>
b) Change to user from support to ubuntu using the below command.

   sudo su ubuntu
c) Run the restore application command using the below mentioned command. This will restore all affected applications. 
 java -Dpolicy.config.path=/home/ubuntu/build-target/server-utils/policy/ -Ddlf.path=dir:///home/ubuntu/build-target/deployment/dlf -Dtsdb_client.configuration=/home/ubuntu/build-target/restapilayer/tsdb_client.configuration -Dtimeout=30 -Xmx2048M -cp tools-0.001-SNAPSHOT.jar  com.vnera.tools.BackupApplications -m restore
d) Delete the jar file using the below mentioned command
    
rm /home/ubuntu/tools-0.001-SNAPSHOT.jar
e) Exit the terminal session. Run this command twice.

    exit

Additional Information

Impact/Risks:
This issue is seen for Only manually created applications and not Service Now apps or Flow-based.

Attachments

tools-0.001-SNAPSHOT get_app