Aria Operation for Network Under Account and data source page shows data source error NSX-T data source shows "Data collection failed due to an error. Please wait for some time."
search cancel

Aria Operation for Network Under Account and data source page shows data source error NSX-T data source shows "Data collection failed due to an error. Please wait for some time."

book

Article ID: 324455

calendar_today

Updated On:

Products

VMware Aria Operations for Networks

Issue/Introduction

Below 2 symptoms are observed:

  • Under the NSX-T data source, the box "Enable latency metric collection" is ticked.

         

 

  • Collector logs have this exact backtrace
2021-12-06T11:01:51.332Z ERROR dataprovider.utils.HttpUtils NSXT_###.##.###.##_Config_OpMgr-1 checkCodeAndThrow:53 Could not get response for /api
/v1/service-configs, status 400
2021-12-06T11:01:51.332Z ERROR dataprovider.utils.HttpUtils NSXT_###.##.###.##_Config_OpMgr-1 checkStatusAndThrow:41 API /api/v1/service-configs e
rror response {
 "httpStatus" : "BAD_REQUEST",
 "error_code" : 41013,
 "module_name" : "service-config",
 "error_message" : "ServiceConfig precedence value 1 is duplicate for given profile type [LatencyStatProfile]. Specified value is present in ServiceConfig ServiceConfig/832afafc-###-####-####-1c1256f7e211"

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware vRealize Network Insight 6.9
VMware Aria Operations for Networks 6.10
VMware Aria Operations for Networks 6.11
VMware Aria Operations for Networks 6.12
VMware Aria Operations for Networks 6.12.1
VMware Aria Operations for Networks 6.13
VMware Aria Operations for Networks 6.14

Cause

This issue is usually seen when VMware Aria Operations for Networks Collector was either shut down or a data source was added to another collector.
This error indicates VMware Aria Operations for Networks did not get the chance to clear off the latency profile it created and now AON is trying to create a profile afresh.

Resolution

The permanent solution before we can enable Latency is to clear older config.

  1. Disable or uncheck the "Enable latency metric collection" check under edit datasource page for NSXT on the VMware Aria Operations for Networks GUI

  2. Edit NSXT datasource and uncheck the Latency profile check box

  3. Get all service configs by calling API https://nsx-ip/api/v1/service-configs/ (GET API) [POSTMAN]
    Identify VMware Aria Operations for Networks created service config (it will have name prefix format as “vRNI-Service_Config_Profile_”


    Example:

     "profiles": [
             {
                   "profile_type": "LatencyStatProfile",
                   "target_id": "4452cb73-###-####-####-c4310c4f5331",
                   
    "target_display_name": "vRNI-Latency_Stat_Profile_RFIxUjVTOA==",
                   
    "target_type": "UpmProfile",
                   
    "is_valid": true
             
    }

    Note: in some cases the API will return pagiated results. If you do not file the profile you are expecting, scroll to the bottom of the results and if a cursor parameter is present, you should run the API call again with the cursor parameter, e.g.

    https://nsx-ip/api/v1/service-configs?cursor=<cursor>

  4. Delete that particular service config again via API by using the corresponding ServiceConfig> id

    e.g.: Delete API https://nsx-ip/api/v1/service-configs/<service-config-id>

  5. Enable or check the "Enable latency metric collection" checkbox under edit data source page for NSXT on the VMware Aria Operations for Networks GUI.

    At this time no errors should be seen and data source should have been submitted successfully.
  6. Observe the environment and if the error message appears back again in next few hours then:

Broadcom Support will have to review and evaluate this further and make changes to Aria Operations for Networks database. Open a case with Broadcom Support and reference this KB article (324455). See Creating and managing Broadcom support cases.