vSphere Integrated Containers Management Portal not accessible after VIC Appliance intialization
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vSphere Integrated Containers Management Portal not accessible after VIC Appliance intialization

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Article ID: 324446

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides steps to troubleshoot and discusses the fix for when the VIC management portal is not accessible because of above mentioned exception.

Symptoms:

  • After the VIC appliance has been initialized successfully, VIC Management portal web page is not accessible on URL https://<FQDN>:8282 
  • Login to the VIC appliance through ssh using the root credentials, Check the admiral services status by running command - # systemctl status admiral.service
  • The admiral service is in failed state and below highlighted exception can be seen in the command output -
May 21 18:30:27 <hostname> start_admiral.sh[920289]: + java -Djava.util.logging.config.file=/admiral/config/logging.properties -Dconfiguration.properties=/admiral/config/dist_configuration.properties,/configs/config.properties -Ddcp.net.ssl.trustStore=/configs/trustedcertificates.jks -Ddcp.net.ssl.trustStorePassword=changeit -Dencryption.key.file=/var/admiral/8282/encryption.key -Dinit.encryption.key.file=true -Xmx1280M -Xms1280M -Xss256K -Xmn256M -XX:MaxMetaspaceSize=256m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/admiral/ -XX:+ExitOnOutOfMemoryError -cp '/admiral/*:/admiral/lib/*:/etc/xenon/dynamic-services/*' -Dservice.document.version.retention.limit=50 -Dservice.document.version.retention.floor=10 -Dxenon.ServiceErrorResponse.disableStackTraceCollection=true com.vmware.admiral.host.ManagementHost --bindAddress=0.0.0.0 --port=-1 --sandbox=/var/admiral/ --publicUri=https://<hostname>:8282/ --bindAddress=0.0.0.0 --port=-1 --authConfig=/configs/psc-config.properties --securePort=8282 --keyFile=/configs/server.key --certificateFile=/configs/server.crt --startMockHostAdapterInstance=false
May 21 18:30:27 <hostname> start_admiral.sh[920289]: Exception in thread "main" java.lang.IllegalArgumentException: publicUri should be a non empty absolute URI
May 21 18:30:27 <hostname> start_admiral.sh[920289]: at com.vmware.xenon.common.ServiceHost.initialize(ServiceHost.java:743)
May 21 18:30:27 <hostname>start_admiral.sh[920289]: at com.vmware.xenon.common.ServiceHost.initialize(ServiceHost.java:706)
May 21 18:30:27 <hostname>start_admiral.sh[920289]: at com.vmware.admiral.host.ManagementHost.initialize(ManagementHost.java:228)
May 21 18:30:27 <hostname> start_admiral.sh[920289]: at com.vmware.admiral.host.ManagementHost.initializeHostAndServices(ManagementHost.java:177)
May 21 18:30:27 <hostname> start_admiral.sh[920289]: at com.vmware.admiral.host.ManagementHost.main(ManagementHost.java:155)



Environment

VMware vSphere Integrated Containers 1.5.x

Cause

vSphere Integrated Containers Management Portal is controlled by admiral service running on VIC appliance. So this issue occurs when the admiral service is unable to start because of exception "publicUri should be a non empty absolute URI". The public URI is the FQDN that is configured at the time of VIC appliance. So please verify if any underscore(s) are part of the FQDN such as www.my_example.com. Having an underscore in FQDN is not supported by admiral service hence the service fails to start and gives out an exception.

Resolution

  1. Login to the vCenter where VIC appliance is running using the Flex based client.
  2. Shutdown VIC appliance using the "Shutdown Guest OS" option or run "shutdown now" command in the VIC appliance ssh shell.
  3. Follow below path and remove any underscore from the FQDN in VIC appliance vAPP Options -
Select VIC appliance VM > Edit Settings > vApp Options > Expand Networking Properties > Make changes in the FQDN box
  1. Save the Settings.
  2. Power On the appliance.
  3. Now the admiral service should start successfully and VIC Management Portal should be accessible.