Error: "Internal Server Error" and "Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException" when interacting with an Organization VDC
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Error: "Internal Server Error" and "Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException" when interacting with an Organization VDC

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Article ID: 324407

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to make any changes to an Organization vDC (Org vDC).
  • Unable to power on a virtual machine in VMware Cloud Director (VCD). 
  • When performing these actions you see an Internal Server Error and the following error is present in the Task Details:

    Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException

  • Within /opt/vmware/vcloud-director/logs/vcloud-container-debug.log errors like follows are observed:

    2024-11-06 14:45:24,489 | ERROR  | compute-fabric-activity-pool2 | GenericVirtualResourcePool   | vrp <orgvdc name> (<vdc-id>):########-####-####-######## - Failed to retrieve info of resource pool

    2024-11-06 14:45:25,353 | ERROR  | task-service-activity-pool-7 | VdcService           | Error updating VDC | requestId=<request-id>.,request=PUT https://vcloud.example.com/api/admin/vdc/<vdc-id>,requestTime=1730904323305,remoteAddress=<ip-address>.:59243,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:131.0) Gecko/201...,accept=application/*+json;version 39.0.0-alpha vcd=########-####-####-########,task=task-id> activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:<uuid>)
    com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException
        at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.getResourcePoolInfo(GenericVirtualResourcePool.java:1153)

Environment

VMware Cloud Director 10.x

Cause

This issue can occur if the Cloud Director inventory of objects is not fully synchronized with the vCenter Server and there is a mismatch between the inventories about the resource pool object backing the Org vDC.

Resolution

To resolve this issue, perform the following to synchronize the Cloud Director and vCenter Server inventories.

  1. Log into the Cloud Director Provider Portal as a System Administrator user.
  2. Navigate to Resources > Infrastructure Resources > vCenter Server Instances.
  3. Select the vCenter Server object and click Reconnect.
  4. Once vCenter Server is in connected again, test if the issue is resolved.

If the issue persists,  contact Broadcom Support and note this Article ID (324407) in the problem description. For more information, see Creating and managing Broadcom support cases.