"Failed to subscribe products: Error in fetching token catalog:" error is thrown while trying to subscribe solutions from Marketplace to vCD.
search cancel

"Failed to subscribe products: Error in fetching token catalog:" error is thrown while trying to subscribe solutions from Marketplace to vCD.

book

Article ID: 324405

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

To be able to subscribe the solutions from Marketplace to vCD successfully.


Symptoms:
  • 400 BAD REQUEST error is seen in the Network tab of the Browser logs.

{"response":{"message":"Error in fetching token catalog: "}}

 

  • vcloud-conatiner-debug.log has the below entries:

2024-02-28 xx:xx:49,627 | DEBUG  | pool-jetty-83094     | OAuthTokenServiceImpl     | Failed to generate access token | requestId=xxxxxx26-xxxx-xxxx-xxxx-x1fxxxccxxxx,request=POST https://vcloud-site/oauth/tenant/Tenant_name/token,requestTime=1709110189392,remoteAddress=1xx.xxx.xx.x:5xx18,userAgent=go-vcloud-director,accept=application/*;version 36.1

com.vmware.vcloud.api.rest.toolkit.oauth.exceptions.OAuthException: Missing the following rights to perform this operation: API Tokens: Manage 

at com.vmware.vcloud.token.impl.OAuthTokenServiceImpl.createSessionAndAccessToken(OAuthTokenServiceImpl.java:148)


Cause

Communication from Marketplace is not reaching the vCD instance.

Resolution

  • Egress IP's of Marketplace should be whitelisted in Firewall configuration for vCD cells.
  • Open the Marketplace portal in the browser: https://marketplace.cloud.vmware.com
  • Navigate to Settings -> Egress IPs and whitelist the Egress IP(s) shown in the vCD Firewall settings.

 

 

Once the Egress IPs are whitelisted, we should be able to subscribe to the catalogs successfully.

Additional Information

How do I deploy a solution on VMware Cloud Director?- https://docs.vmware.com/en/VMware-Marketplace/services/vmware-marketplace-for-consumers/GUID-37494F09-58F4-439B-B708-F78184DA47C4.html