New appliance VM deployed from content library is not functioning
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New appliance VM deployed from content library is not functioning

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Article ID: 324369

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The appliance VM was recently deployed via a Content Library in vCenter and one of the following symptoms is present:

  • The appliance VM displays the following message on the console for longer than expected
Firstboot is running, please wait
  • The first log in as root on the console does not prompt to set the root password. The root password is unknown.

  • Entries like below in the /var/log/firstboot/vcopssuitevmmount.log
ERROR: Cannot create LV core.
ERROR: Storage setup has failed. Interrupting the LVM partitions initialization. Exiting from the installation script.
  • The appliance VM displays the following error on the console after power on
NO NETWORK DETECTED. PLEASE CHECK THE NETWORK CONFIGURATION
For more details login and examine the following log
/opt/vmware/var/log/vrops_network_manager.log
  • The Aria Operations cluster is offline due to out of disk space error and following the steps from Adding additional storage to a node in Aria Operations does not resolve the issue.

Environment

VMware Aria Operations 8.x (formerly vRealize Operations)

Cause

The hard disk configuration of the appliance VM is corrupted when deploying via Content Library

Expected disk layout for Analytic Appliance VMs (primary, replica, data)

Hard disk 1 - 20 GB
Hard disk 2 - 250GB
Hard disk 3 - 4 GB

Expected disk layout for Cloud Proxy Appliance VMs:

Hard disk 1 - 20 GB
Hard disk 2 - 120GB

Resolution

To resolve the issue, the appliance VM(s) must be redeployed.


Method 1 - Redeploy directly from ova file

  1. Obtain the ova file from the Broadcom Support Portal
  2.  Follow the directions in Create a Node by Deploying an OVF


Method 2 - Redeploy from content library

  1. Redeploy the template from the Content Library in vCenter.
  2. Prior to powering on the appliance VM, right click the VM and select Edit Settings.
  3. Click the vertical 3 dot button next to Hard disk 2 and select Remove device and data
  4. Click Add New Device and select Hard Disk
  5. Set the New Hard Disk size according to the node type
    • For Analytic Appliance VMs (primary, replica, data) set the size to 250 GB
    • For Cloud Proxy Appliance VMs set the size to 120 GB
  6. Power on the appliance VM