PSOD Failed to validate acceptance levels
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PSOD Failed to validate acceptance levels

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Article ID: 324264

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
 
After an upgrade, the ESXi system halts on a purple diagnostic screen (PSOD) with the following text.

The system has found a problem on your machine and cannot continue.
Failed to validate acceptance levels: Expected (accepted) found vibs with (partner) acceptance level

Environment

VMware vSphere ESXi 8.0.1

Cause

This problem may occur if acceptance level is set to VMwareAccepted, but upgrade is done using boot-to-ISO method with a partner customized ISO that contains VIBs with PartnerSupported level.

Resolution

No clean resolution is possible.

Workaround:
  • Rollback the version using Shift+R

  • Set the acceptance level to PartnerSupported.
        # esxcli software acceptance get
        # esxcli software acceptance set level=PartnerSupported

  • Retry the upgrade

Additional Information


Reverting to a previous version of ESXi
https://knowledge.broadcom.com/external/article?legacyId=1033604

Manage the Acceptance Levels of Hosts and VIBs
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/7-0/vsphere-security-7-0.html