vCenter upgrade stuck during VCENTER UPGRADE POST VALIDATION task
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vCenter upgrade stuck during VCENTER UPGRADE POST VALIDATION task

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Article ID: 324045

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • The article provides steps to work around the issue while update vCenter through SDDC Manager subtask "VCENTER UPGRADE POST VALIDATION task" failed.


Symptoms:
  • During vCenter upgrade through SDDC Manager - VCENTER UPGRADE POST VALIDATION subtask keeps running for a long time and eventually failed.
  • When checking vCenter found it updated to the target version without any issues
  • On SDDC manager lcm.log could see the following error:

 

2021-07-09T07:56:22.591+0000 INFO [vcf_lcm,d88cfd9bef586517,af58,upgradeId=d1aa2c15-ab65-4aed-bc30-467c58af0564,resourceType=VCENTER,resourceId=440edf8a-b034-487d-a8c9-f2409b7a69bc,bundleElementId=260ec42c-2705-4782-bf44-7160eb462ddf] [c.v.e.s.l.c.utils.SshCommandRunner,ThreadPoolTaskExecutor-3] Command '[/bin/appliancesh -c system.version.get]' output:
Exit Code 0: Unknown command: `/bin/appliancesh'


Environment

VMware Cloud Foundation 4.x

Cause

  • The default shell after vCenter update installation should be bash.
  • The command /bin/appliancesh -c system.version.get failed to execute to return the current vCenter version to be verified by SDDC manager.

Resolution

This is a known issue in VCF 4.x.

Workaround:
  1. Make sure that the default shell is an appliance shell before the start/schedule of the VC upgrade.
  2. Log in to the vCenter Server Appliance through SSH.
  3. Type shell and press Enter.
  4. In the temporary BASH shell, run this command to permanently configure the default Shell to BASH for Root:
# chsh -s /bin/bash root


Additional Information

For more information about toggling the vCenter Server Appliance default shell,See 2100508