Expanding a vRA / vROps cluster in a VMware Cloud Foundation may fail for 'createVcfLb'
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Expanding a vRA / vROps cluster in a VMware Cloud Foundation may fail for 'createVcfLb'

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Article ID: 324033

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
  • In an upgraded VCF 4.x environment with a manually configured NSX-T load-balancer, attempts to expand a vRA or vROps cluster from vRSLCM may fail on 'createVcfLb'
  • Additionally, there is a failed "Deploy and Configure NSX-T Load Balancer" workflow in SDDC-Manager.
  • In NSX-T there are duplicate records for Server Pools/ Application Profiles/ Persistence Profiles/ Monitors.


Environment

VMware Cloud Foundation 4.x

Cause

SDDC Manager creates a Load Balancer workflow as it is not aware of an existing manually configured Load Balancer with the given IP.

Resolution

This is a known issue affecting VMware Cloud Foundation 4.1 and 4.2 and will be fixed in a future release.

Workaround:
  1. Open a browser to theNSX-T UI and login.
  2. Navigate to Networking -> Load Balancing -> Virtual Servers and delete the virtual servers, both https and http-redirect) for the given product that you are trying to expand.
  3. Go to SDDC Manager UI and retry the failed "Deploy and Configure NSX-T Load Balancer" task. This will create a new Virtual Server and associate the newly created(duplicate) records of the Server Pools/ Application Profiles/ Persistence Profiles/ Monitors to the newly created Virtual Server.
  4. As the old records for Server Pools/ Application Profiles/ Persistence Profiles/ Monitors in NSX-T will no longer be needed, these can safely deleted:
    1. In NSX-T UI, navigate to Networking -> Load Balancing -> Server Pools and delete the Server Pool for the given product that has 0 Virtual Servers associated with it.
    2. Navigate to Networking -> Load Balancing -> Profiles, select Profile Type: Application
    3. Delete the Application Profiles for the given product that have 0 Virtual Servers associated with them.
    4. Change the Profile Type to Persistence and delete the Persistence Profiles for the given product that have 0 Virtual Servers associated with them.
    5. Navigate to Networking -> Load Balancing -> Monitors, select Monitor Type: Active, and delete the monitor for the given product that has 0 Server Pools associated with it.