Deployment of vRealize Operations Manager is failing with the error: 'Failed to update the password'
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Deployment of vRealize Operations Manager is failing with the error: 'Failed to update the password'

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Article ID: 323997

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
  • The reported error is 'Failed to update the password. You can send a new password update request by making sure the current password is correct and the new password has not been already used.'
  • Authentication to the vROps node for which the deployment is failing by using the provided in the JSON / XLS password.


Cause

vROPs node's password is locked. Possible cause is too many invalid login attempts to the node performed by the user.

Resolution

Overview:
Reset the password of the vROPs node by providing the same password that is specified in JSON / XLS and then retry the execution from Cloud Builder.

Instructions:
  1. Linux keeps the old password stored in /etc/security/opasswd. Delete the line which contains the user whos password needs to change.
  2. Also check the file /etc/pam.d/common-password and look for a line with the parameter remember.  This is what tells pam_unix to remember the passwords in /etc/security/opasswd.
password required pam_pwhistory.so use_authtok remember=6 retry=3
  1. Then update the password by using passwd:
passwd

Example output
Changing password for root.
New Password:
Reenter New Password:
Password has been used already. Choose another.
Password changed
  1. Retry the task from Cloud Builder.


Additional Information

For more information on resetting the root password in vRealize Operations, see KB 2001476.