How to Reset the API Token for the Hosted NSX Analyst API
search cancel

How to Reset the API Token for the Hosted NSX Analyst API

book

Article ID: 323926

calendar_today

Updated On:

Products

VMware

Issue/Introduction

This document will explain how to reset the API Token.

Symptoms:
You have lost or can not remember what the API Token is for your Hosted NSX Analyst Product.

Cause

We do not have a way to look up the original API Token provided to you when you received your license for the Hosted NSX Analyst product. If you reset API Token, the original Token will no longer be valid. Users using this Token must update existing API calls. The API Key remains unchanged and is the License Key for the product.

Resolution

Find the License page in your Portal.

Admin → Licensing

Be sure to click on the Reset API token icon for the appropriate Hosted license - Lastline Analyst API Hosted.

ercot-2.png
 


Workaround:
Reset the API Token from the Portal UI.

Additional Information

Refer to the VMware NSX Network Detection and Response System Administration Operations Guide
https://user.lastline.com/lastline-pdf-opsguide-manuals/Administration_Operations_Guide.html

Impact/Risks:
You can not make API calls without a valid API Token and API Key.