IX appliance tunnel DOWN with error "Service Pipeline is Down"
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IX appliance tunnel DOWN with error "Service Pipeline is Down"

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Article ID: 323675

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Updated On:

Products

VMware HCX VMware Cloud on AWS VMware Cloud on Dell EMC

Issue/Introduction

  • HCX IX appliance transport tunnel will remain up, but the appliance will show "Service pipeline status is down".



Environment

VMware HCX

 

Cause

The condition where the transport tunnel remains UP while the Service Pipeline is DOWN, is an indication of communication problems between the Interconnect (IX) and the WAN Optimization (WO) appliances in the Service Mesh.

Resolution

  • The current Service Pipeline Down status is directly attributed to a communication failure between the Interconnect (IX) appliance and the WAN Optimization (WAN-OPT) appliance. This communication failure is specifically caused by the WAN-OPT services being disabled on the appliance.

  • The below section outlines the schedule for the mandatory disablement of the WAN Optimization (WAN-OPT) service based on the currently deployed HCX release version.

    • The WAN-OPT service will be disabled and rendered non-functional according to the following timeline:

      HCX Version Range Service Decommissioning Date Status/Action
      Up to HCX 4.11.0 30-Nov-25 The service will be disabled and non-functional starting this date.
      HCX 4.11.1 to 4.11.2 31-Dec-25 The service will remain functional until this date, after which it will be disabled.
      HCX 4.11.3 and VCF 9.0 N/A (Already Removed) The WAN-OPT Appliance functionality has already been removed in these versions.

Resolution for the IX tunnel down with WAN-OPT enabled:

  • Remove WO (WAN Optimization) appliance from Service Mesh to restore migration services. Removing WAN Optimization from the Service Mesh will NOT impact the IX or any NE appliances.

    Steps to Remove WO:

    1. Navigate to the Service Mesh that is going to be edited.
    2. Select the "Edit" option on the Service Mesh.
    3. On the "Select Services to be enabled" tab, unselect WAN Optimization
    4. Continue to the end of the Service Mesh edit wizard, and select SAVE.
    5. Allow the Service Mesh to resync.
      • You don't need to use [RESYNC] button. Resync is triggered by the [SAVE] button.

  • Please refer the following KB for more information on  Deprecation of WAN Optimization in VMware HCX

Additional Information

Active migrations and newly created migrations will be impacted while the Service Pipeline is down. VR Bulk and RAV migrations waiting for cutover should not be affected if the workaround is applied promptly to limit the impact to periodic delta sync replications.

There is no impact to Network Extension Appliances.

HCX WAN Optimization is deprecated in HCX 4.11 and will be removed in a future release.
For more information, VMware HCX 4.11 Release Notes.