HCX Network Extension task fails with error "Failed NSX-T Request"
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HCX Network Extension task fails with error "Failed NSX-T Request"

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Article ID: 323671

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Updated On:

Products

VMware HCX VMware NSX

Issue/Introduction

  • Creating Network Extension fails with the following error in Audit Logs of HCX UI:
    Failed NSX-T request:
    { "url": "method": "GET" } Got response : { "status": "failure", "statusCode": 403, "details": "", "result": { "module_name": "common-services", "error_message": "The credentials were incorrect or the account specified has been locked.", "error_code": 403 } }"
  • When logging into HCX Manager Appliance Management Interface at <https://hcx-ip-or-fqdn:9443>, NSX connection status is displaying a red status indicator, signaling an issue with NSX.
  • When logging into the NSX-T UI with admin, it fails indicating invalid credentials.

Cause

The issue is caused due to expired NSX admin password. When the NSX admin password expires, NSX will be un-registered with HCX and any new HCX Network Extension tasks will fail.

Resolution

  • If you confirmed that the password is expired in NSX, go through the following documentation to reset the password: Resetting the Passwords of an Appliance.
  • Once the admin password has been reset, navigate to theHCX Manager Appliance Management Interface at <https://hcx-ip-or-fqdn:9443>  and enter the updated NSX-T admin credentials followed by the restart of Web and Application services at Appliance Summary tab.
    Note: Please make sure that there are no active HCX Migrations happening when restarting Web and App services as the migrations may fail. 
  • If HCX is still not connecting to NSX after re-entering the NSX credentials, please follow the steps mentioned in the resolution field of the following KB:
    HCX Service Mesh Alterations or Migrations Fail Due to NSX-T API Authentication Failure