[HCX] "Failed NSX-T Request" when extending a network
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[HCX] "Failed NSX-T Request" when extending a network

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Article ID: 323671

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Updated On:

Products

VMware HCX VMware NSX

Issue/Introduction

Provide a resolution when the above error is being seen.

Symptoms:
The following error may be seen when attempting to extend a network in HCX -"Failed NSX-T request : { "url": "method": "GET" } Got response : { "status": "failure", "statusCode": 403, "details": "", "result": { "module_name": "common-services", "error_message": "The credentials were incorrect or the account specified has been locked.", "error_code": 403 } }"

When logging into the HCX VAMI (on port 9443), NSX is reporting a red dot, indicating NSX is not registered with HCX. When logging into the NSX-T UI with admin, it fails indicating invalid credentials.

Cause

This is due to the NSX admin password expiring. When the NSX admin password expires, NSX will be un-registered with HCX and any new HCX extensions will fail.

Resolution

Validate NSX is showing a red dot in the HCX VAMI, and it is failing to login to the NSX-T UI with the admin credentials. If both of these are validated, then proceed with resetting the expired admin password using the following document - https://docs.vmware.com/en/VMware-NSX-T-Data-Center/3.2/administration/GUID-8816B842-2EC4-40A8-A618-F68DB29FABD2.html.

Note: If root is also expired, the process under "Procedure" can be followed in that same document above.

Once the admin password has been reset, login to the HCX VAMI (on port 9443) and edit the current NSX credentials and add the new admin password.

If it fails to add the password, please delete the current NSX registration, reboot the HCX Manager, and re-register NSX in HCX using the same NSX URL, admin and the new admin password.

Additional Information

NSX Requirements for HCX Deployments

Impact/Risks:
No new network extensions can be created until NSX is re-registered with HCX.