[HCX] Unable to change or update IP range in HCX Network Profile.
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Article ID: 323659
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Updated On:
Products
VMware HCXVMware Cloud on AWS
Issue/Introduction
To address the issue faced when attempting to modify the IP range for a given Network Profile while it is in-use.
Symptoms: When attempting to modify the IP range for a given network profile, the below error is received: "Some of the affected IPs from the pool are in use".
Cause
Some of the IP addresses in the range were already in use by a deployed HCX Service Mesh. The customer needs to modify said Network Profile to allow for Service Mesh Appliance expansion and growth.
Resolution
Deploy HCX with a Network Profile CIDR range large enough that allows for ample expansion over time.
Workaround: There are two ways to work around this issue - Both will require planned downtime to implement the changes:
Unextend any L2E's running on the configured NEs. Remove the configured HCX Service Mesh. Make the Network Profile IP CIDR range changes as required. Redeploy the HCX Service Mesh using the now expanded Network Profile IP CIDR range. Reconfigure the L2Es.
Modify the Service Mesh to use a temporary, most commonly "externalNetwork", Network Profile for a short period of time. Save these changes and allow for the Service Mesh appliances to be redeployed. Once redeployed with the temporary Network Profile in place, modify the problematic Network Profile, expanding the IP CIDR range. Once modified, reconfigure the Service Mesh to once again use the desired Network Profile (which includes the expanded range). Allow for the Service Mesh appliance to be redeployed.
Additional Information
Impact/Risks: Services relying on Network extension will be affected during this action. Any in-flight migrations will need to be paused and resumed.