Unable to attach an AWS Direct Connect VIF to VMware Live Cyber Recovery
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Unable to attach an AWS Direct Connect VIF to VMware Live Cyber Recovery

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Article ID: 323658

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Updated On: 01-28-2025

Products

VMware Live Recovery

Issue/Introduction

  • When attempting to attach an AWS Direct Connect (DX) VIF in VLCR, the following error is seen

You need to configure Direct Connect in AWS, and create virtual interfaces on your AWS account with the owner set to account ID




  • A Direct Connect (DX) VIF has been created for use with VLCR for private connection.
  • It is created in the same AWS shadow account as VLCR.
  • The VIF and VLCR are located in different regions.
  • The VIF does not show in the DX Dialog Box as available. 
  • This is preventing the VIF from being attached in VLCR.

Environment

VMware Live Cyber Recovery 7.27.x

VMware Live Cyber Recovery 7.26.x

Cause

This error will be seen when the AWS DX VIF is deployed in a different region than the VLCR deployment region Or if the VIF is terminating in a different region other than VLCR deployment region. 

Resolution

Note: Verify all the prerequisites have been followed: Configure Direct Connect (Private VIF)

Attaching an AWS DX VIF that is in a different region than the VLCR deployment region is currently not supported. 


Workaround:


If there is a requirement to attach an AWS DX VIF that is in a different region than the VLCR deployment region or the one terminating in a different region, please open a support case with VMware by Broadcom  and provide below information

1) The Org ID associated to the environment

2) The AWS DX VIF name.

3) VLCR and DX deployment regions