[VCDR] Direct Connect VIF BGP Status Down
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[VCDR] Direct Connect VIF BGP Status Down

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Article ID: 323647

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Provide the resolution to get the BGP Status UP for the Direct Connect VIF attachment.

Symptoms:
After attaching a Direct Connect VIF in VCDR, the BGP status is "Down" in the VCDR UI, and "Pending" is showing in the AWS UI. It is confirmed VCDR and the Direct Connect VIF are deployed in the same region (This is a requirement - https://kb.vmware.com/s/article/96080?lang=en_US). 

VCDR UI Example:
image.png
AWS UI Example:
image.png

Cause

This is a known issue in the current VCDR version. It is due to an exception during the VCDR Direct Connect setup.

Resolution

This issue is expected to be resolved in a future VCDR release.

Workaround:
Please create a Support Request with Broadcom Support with the ask to restart the PINCProvisioning procmgr service. When filing the Support Request, please provide the below information:

- ORG ID
- VCDR Region and Direct Connect VIF Region (Ensure they are the same)
- VCDR Support Bundle ID
- Screenshot of the VCDR UI DX Setup
- Screenshot of the AWS UI Direct Connect
- Provide a time to restart the service (Date and Time)

Note: When restarting the PINCProvisioning procmgr service, it will impact any running PG snapshots, and will auto restart them when the service comes back up. Also, no failovers can be running at the time of the service restart.

Additional Information

Configure Direct Connect (Private VIF)

Impact/Risks:
The BGP status will remain down in the VCDR UI, until the PINCProvisioning procmgr service on IRR is restarted.