vUSB0 Flapping up/down Causing Hosts Default Gateway to Change
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vUSB0 Flapping up/down Causing Hosts Default Gateway to Change

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Article ID: 323602

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction


Symptoms:The 

  • ESXi host may show as disconnected in vCenter intermittently.
  • When logging into the Console of the ESXi host and going to the DCUI --> Configure Management Network, you will see that the default gateway has changed. In some cases, the gateway changed to  0.0.0.0 or 6.6.6.6.
  • In /var/run/log/vmkernel.log, the following log snippets regarding the vUSB device will be observed:
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 753073480us: [vob.net.pg.uplink.transition.down] Uplink: vusb0 is down. Affected portgroup: IMM_Network0. 0 uplinks up. Failed criteria: 128
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 753505862us: [vob.net.vmnic.linkstate.up] vmnic vusb0 linkstate up
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 753506082us: [vob.net.pg.uplink.transition.up] Uplink:vusb0 is up. Affected portgroup: IMM_Network0. 1 uplinks up
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 754650354us: [esx.problem.net.connectivity.lost] Lost network connectivity on virtual switch "vSwitchUSB0". Physical NIC vusb0 is down. Affected port groups: "IMM_Network0"
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 754651948us: [esx.clear.net.connectivity.restored] Network connectivity restored on virtual switch "vSwitchUSB0", portgroups: "IMM_Network0". Physical NIC vusb0 is up
YYYY-MM-DDTHH:MM:SSZ: [ClockCorrelator] 1345805528us: [vob.clock.correction.adjtime.sync] system clock synchronized to upstream time servers
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 2751657018us: [vob.net.firewall.port.hooked] Port vmk2 is now protected by Firewall.
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 2751696294us: [esx.audit.net.firewall.port.hooked] Port vmk2 is now protected by Firewall.
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 4514870409us: [vob.net.pg.uplink.transition.down] Uplink: vusb0 is down. Affected portgroup: IMM_Network0. 0 uplinks up. Failed criteria: 128
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 4515304140us: [vob.net.vmnic.linkstate.up] vmnic vusb0 linkstate up
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 4515304364us: [vob.net.pg.uplink.transition.up] Uplink:vusb0 is up. Affected portgroup: IMM_Network0. 1 uplinks up
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 4516650199us: [esx.problem.net.connectivity.lost] Lost network connectivity on virtual switch "vSwitchUSB0". Physical NIC vusb0 is down. Affected port groups: "IMM_Network0"
YYYY-MM-DDTHH:MM:SSZ: [netCorrelator] 4516651799us: [esx.clear.net.connectivity.restored] Network connectivity restored on virtual switch "vSwitchUSB0", portgroups: "IMM_Network0". Physical NIC vusb0 is up



Environment

VMware vSphere ESXi 6.7

Cause

Known issue with Lenovo vUSB0 devices.

Resolution

Disable the vUSB device in the Remote Management Console of the host and remove the standard switch being created on the host. If the Standard switch is re-created automatically, perform the workaround below.

Workaround:

  1. Enable the Ethernet over USB and restart XCC 
  2. Then, once it is responding again, disable Ethernet over USB, delete the standard switch it was creating, and restart XCC again. 
  • Note: XCC =  Remote management console module of the host
    If the above does not resolve the issue, then the vUSB should be disabled at the BIOS level.

  • The above steps and XCC “Lenovo XClarity Controller” are only for a specific server model called Lenovo ThinkSystem.
    Please note that these steps can vary and change from a server model/vendor

     



Additional Information

Impact/Risks:
Kindly check with the Server Vendor to determine the risk involved in disabling this vUSB device.