Report email received without attachment
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Report email received without attachment

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Article ID: 323491

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

When attempting to email a report using the reporting GUI, the email is received without attachment. The goal of this knowledge base article is to describe an issue in the tomcat server which can impact sending reports via emails. 


Note: The issue is not related to having appropriately configured resourcelinks in the APG.xml for time-series data or having a mis-configuration the Frontend Report Generator.




Environment

Watch4Net/M&R - 7.x

Cause

The issue with emails not going out with attachments can be caused by external utilities such as geronimo-javamail_1.4_spec-1.7.1.jar which is used to automate LDAP authentication, and for forwaring emails.

Resolution

The "geronimo-javamail_1.4_spec-1.7.1.jar" file is not part of the M&R distribution, as such it is not supported, and will cause problems with email attachments not going out. If the "geronimo-javamail_1.4_spec-1.7.1.jar" file exists do the following:

1. Usually  "geronimo-javamail_1.4_spec-1.7.1.jar" will reside in the tomcat server in the following location:
    /APG_HOME/Web-Servers/Tomcat/default/lib/geronimo-javamail_1.4_spec-1.7.1.jar

2. If the file exists in the location rename the file or remove the file. 
3. Restart tomcat and see if you can send the emails with the attachments.

Workaround:
There are no work arounds. Geronimo Javamail is not supported by Watch4net/M&R..

Additional Information

Impact/Risks:
An email with the report attachment will not be received by the configured recipient, regardless of the selected format (.CSV, PDF, Excel)