Upgrading Aria Operations 8.x to later version is failing with error that Pak file is not in zip format
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Upgrading Aria Operations 8.x to later version is failing with error that Pak file is not in zip format

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Article ID: 323464

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Upgrading Aria Operations fails with error similar to Error: PAK MANAGER: PAK file /storage/db/casa/pak/dist_pak_files/cargo/reservedTemp_################.pak is not in .zip format.
  • When querying the downloaded pak file for MD5/SHA 256 checksum using Powershell both checksums does not match the values in the Broadcom portal.  
    • Sign into Broadcom Support Portal as per Download Broadcom products and software kb. 
    • Click My Downloads > VMware Aria Operations > VMware Aria Operations > Select the chosen release version
    • Take note of SHA 2 and MD5 checksum for the upgrade pak file you have chosen
    • Open Windows Powershell on the machine where the upgrade pak file is downloaded to and run
      • Get-FileHash <filename> -Algorithm SHA256
      • Get-FileHash <filename> -Algorithm MD5
    • Compare the Hash with the Hash in the Broadcom Support Portal 
  • Checking MD5 checksum may fail with error "This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms" this can happen if FIPS is enabled on the machine where pak is downloaded to.   However only one checksum needs to match what is in the portal for it to be a valid download
  • Size of the pak file downloaded is the same as the size listed in the Broadcom Support Portal

Environment

Aria Operations 8.x

Cause

The download patch file size is similar to what is in the Broadcom Support Portal but both the SHA256 and MD5 hash do not match.

 

Resolution

Recommendation is to ensure you have enough storage available on the machine where you are downloading the pak file and also where you are uploading to Aria Operations. 

Try downloading the pak file again, if you have still an issue with the pak file not have checksums matching the portal please try download from a different machine or network.