HCX Manager Admin UI 9443 page does not load
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HCX Manager Admin UI 9443 page does not load

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Article ID: 323361

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Updated On:

Products

VMware HCX

Issue/Introduction

  • After upgrading to HCX version 4.8.2, the HCX Manager Admin UI (https://<HCX_manager_IP>:9443) does not load.

  • Below logs are noticed for appliance-management.log under /common/logs/appliance-management/ .
2024-06-27 13:51:30.574 UTC [main, , ] ERROR o.s.boot.SpringApplication- Application run failed
org.springframework.context.ApplicationContextException: Failed to start bean 'webServerStartStop'; nested exception is org.springframework.boot.web.server.WebServerException: Unable to start embedded Tomcat server
Caused by: org.springframework.boot.web.server.WebServerException: Unable to start embedded Tomcat server
Caused by: java.lang.IllegalArgumentException: standardService.connector.startFailed
Caused by: org.apache.catalina.LifecycleException: Protocol handler start failed
Caused by: java.lang.IllegalArgumentException: null
Caused by: java.lang.reflect.InvocationTargetException: null
Caused by: java.io.IOException: Keystore was tampered with, or password was incorrect
Caused by: java.security.UnrecoverableKeyException: Password verification failed
  • When attempting to generate a support bundle (HCX Manager UI >>  Administration >> Troubleshooting >> Collect Core HCX Logs) from the regular HCX Manager UI (https://<HCX_manager_IP>:443) a "Failed to generate the Support Bundle." error is seen in the UI .


 

  • The regular HCX Manager UI (https://<HCX_manager_IP>:443) continues to function normally otherwise.
  • HCX upgrades will also fail until this issue is fixed.

Environment

HCX 4.8

Cause

Issue is caused due to mismatch between secrets used by appliance-management service.

Resolution

This issue will not be noticed in HCX version 4.9 and later.

WORKAROUND:
If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article. HCX team can help to fix the issue on HCX 4.8.2 or earlier versions.
For more information, see Creating and managing Broadcom support cases

Additional Information

Impact/Risks:
The HCX Manager Admin UI (https://<HCX_manager_IP>:9443) is used for administrative purposes and does not have direct involvement in HCX migration and network extensions workflows or their operations
A user may proceed with HCX migration and network extensions workflows via the regular HCX Manager UI (https://<HCX_manager_IP>:443) until this issue is resolved in a future HCX software release