sso および lookupsvc log ディレクトリ内の localhost_access.log および catalina.log が原因で、vCenter Server の /storage/log に空きがなくなる
search cancel

sso および lookupsvc log ディレクトリ内の localhost_access.log および catalina.log が原因で、vCenter Server の /storage/log に空きがなくなる

book

Article ID: 323335

calendar_today

Updated On: 04-24-2025

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

免責事項:これは英文の記事「vCenter Server /storage/log filling up due to localhost_access.log and catalina.log in sso and lookupsvc log directories 」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
 

  1. /storage/log に空きがなくなる

  2. vCenter Server で、/storage/log が 80% を超えているというアラートが継続的に受信される

  3. コマンド「du -hSx /storage/log |sort -rh |head -30」から、次のディレクトリが多くの領域を使用しているという出力が返される。

    • /var/log/vmware/sso/tomcat

    • /var/log/vmware/eam/web

    • /var/log/vmware/lookupsvc/tomcat

    • /var/log/vmware/lookupsvc

    • /var/log/vmware/vsphere-ui
  4. これらのディレクトリに、大量の localhost_access*.log ファイル、catalina*.log ファイル及びthreadmonitor#.log ファイルが配置される。

  5. localhost_access*.log 、catalina*.log 及び threadmonitor#.log が圧縮されない



Environment

VMware vCenter Server 7.0.x

Cause

これらのファイルに対してログのローテーションと圧縮が正常に機能していません。それが原因で、/storage/log パーティションに空きがなくなる可能性があります。

Resolution

この問題は vCenter Server 7.0 Update 3c で解決されています。vCenter Server がすでに 7.0 U3c にアップデートされている場合に、この記事に記載されているのと同様の問題が発生したときは、サポート リクエストを発行して VMware のサポートにお問い合わせください。

Workaround:

注意:以下の手順を実行する前に、vCenter Server Appliance の最新のバックアップまたはオフライン スナップショット (パワーオフ状態)を作成してください。影響を受ける vCenter Server Appliance が拡張リンクモード (ELM) レプリケーショングループに属している場合は、そのすべてのレプリケーションパートナーについてもバックアップまたはオフラインスナップショットを作成する必要があります。ELM vCenter をリストアする場合は、ELM レプリケーションのすべてのメンバーもリストアする必要があります。そうしないと、VMDirectory LDAP データベースに不整合が発生します。

1.このナレッジベースに添付されている「configs.zip」ファイルを、以下に示す vCenter Server Appliance 内の各ファイルにコピーします。
 
configs.zip                 >  Your vCenter Server
-----------                    -------------------
SSO_server.xml              >  /usr/lib/vmware-sso/vmware-sts/conf/server.xml
SSO_logging.properties      >  /usr/lib/vmware-sso/vmware-sts/conf/logging.properties
LOOKSVC_server.xml          >  /usr/lib/vmware-lookupsvc/conf/server.xml
LOOKSVC_logging.properties  >  /usr/lib/vmware-lookupsvc/conf/logging.properties
2. vmware-stsd および lookupsvc サービスを再起動します

# service-control --stop vmware-stsd && service-control --start vmware-stsd
# service-control --stop lookupsvc && service-control --start lookupsvc
3.このナレッジベースの添付ファイル「tomcat_compress_fixed.zip」内にある「tomcat_compress.cron」を、vCenter Server Appliance の /etc/cron.d にコピーします。

スペース使用率の大部分が /storage/log/vsphere-ui ディレクトリから発生している場合は、以下の手順を実行します。
 
1.コマンドを実行してください : du /storage/log/vmware/vsphere-ui -ahx . |sort -rh |head -n 20
 
2. 1 週間以上経過した catalina.log ファイルを削除すると安全です。

例 :  

rm catalina-2023*

3. 1か月以上経過した「threadmonitor[Number].log」をゼロクリアしてください。
[Number]を置き換える必要があります。
 
例:
echo > threadmonitor7.log
 
 

Additional Information

/storage/log に空きがなくなるという同様の動作を発生させる別の問題もあります。ただしこれは、KB326212 で説明されているとおり、/storage/log/vmware/eam/web/ に多数の localhost_access.*.log ファイルが置かれることが原因です。
この 2 番目の問題は、vCenter Server 7.0 Update 3(ビルド 18700403)で修正されました。

以前のバージョンの vCenter Server 7.0 を実行している場合は、KB326212 の手順にも従ってください。

Attachments

tomcat_compress_fixed.zip get_app
configs get_app