[VMC on AWS] vSAN object inaccesible- Unable to power on Virtual Machines
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[VMC on AWS] vSAN object inaccesible- Unable to power on Virtual Machines

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Article ID: 323255

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

The KB helps to understand the issue and offers a solution to it.

Symptoms:
  • Unable to power virtual machines or perform any other operations. 
  • The Virtual machines are participating in WSFC Cluster. 
  • The power options and migrate option are grayed out for the affected VMs
  • You may see error "Unable to enumerate all disks" 
  • Resync shows an object with reduced availability and an ongoing resync but the resync is stuck. 


Cause

The Virtual machines in WSFC cluster are unable to read one or more shared vmdk files. This is because of the lock imposed on the shared vmdks while a resync task is in progress.

Resolution

This is a known issue and is fixed in SDDC version 1.22.x


Workaround:
As a workaround, reboot the host which is holding a lock on the Virtual Machine object. Please contact VMware Support for identifying the host holding the lock and reboot it.

Additional Information

Impact/Risks:
Power on of one or more virtual machines in the WSFC cluster will fail.