SRM server cannot connect to VR on port 8043, warning "N7Vmacore4Http13HttpExceptionE HTTP error response: Bad Request."
book
Article ID: 323206
calendar_today
Updated On:
Products
VMware Live Recovery
Issue/Introduction
Symptoms:
Site Recovery Manager & vSphere Replication have issues post upgrade from 8.6 to 8.7, after successful reconfigure of both SRM and VR appliances. vSphere Replication was first upgraded to 8.7 from 8.6 followed by Site Recovery Manager. Both the version upgrade completed fine, now getting an error as below & the protection group is showing as "Not Configured".
Site Recovery Manager & vSphere Replication 8.8 reregister activity, after successful reconfigure of both SRM and VR appliances, the UI reports an issue between SRM server and the VR server.
Site Recovery UI warning:
SRM Server cannot connect to VR Management Server at '{VRMS FQDN}:8043'. A general system error occurred: N7Vmacore4Http13HttpExceptionE HTTP error response: Bad Request. Reason: HTTP Status 400 – Bad Requestbody font-family:Tahoma,Arial,sans-serif; h1, h2, h3, b color:white;background-color:#525D76; h1 font-size:22px; h2 font-size:16px; h3 font-size:14px; p font-size:12px; a color:black; .line height:1px;background-color:#525D76;border:none;
Environment
VMware Site Recovery Manager 8.x VMware vSphere Replication 8.x
Cause
When Site Recovery Manager (SRM) is unable to resolve the Fully Qualified Domain Name (FQDN) of the vSphere Replication (VR) server, SRM will be unable to establish a connection to the VR Management Server. This issue prevents proper communication and may impact the replication and recovery process.
Resolution
SRM is unable to resolve the FQDN, hence IP can be used instead, please follow below:
Login to the vSphere Replication appliance: https://<vrms-appliance-fqdn>:5480
Change local host in reconfigure in vSphere Replication wizard from FQDN to IP.
Perform the above step on alternate vSphere Replication site.
Reconnect in Site Recovery UI
Workaround
When the Common Name (CN) in a certificate is not a complete Fully Qualified Domain Name (FQDN), applications or services that require strict certificate validation may encounter issues.
Check for the common name (CN) in the VRMS and SRM appliance and make sure that the common name (CN) is same as the FQDN of the VRMS/SRM appliance.
FQDN can be validated by going to the Networking Section of the VRMS/SRM VAMI page
Change the Certificate and Reconfigure the VRMS Appliance.
Additional Information
Note: If the IP address cannot be used for security reasons, then thehostname and the certificate need to be reset using lowercase for the FQDN of the VRMS appliance:
Example : use vrms1.example.com instead of VRMS1.example.com