Site Recovery Manager & Vsphere Replication have issues post upgrade from 8.6 to 8.7
search cancel

Site Recovery Manager & Vsphere Replication have issues post upgrade from 8.6 to 8.7

book

Article ID: 323206

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
Vsphere Replication was first upgraded to 8.7 from 8.6 followed by Site Recovery Manager. Both the version upgrade completed fine, not getting an error as below & the protection group is showing as "Not Configured".
SRM Server cannot connect to VR Management Server at '{VRMS FQDN}:8043'. A general system error occurred: N7Vmacore4Http13HttpExceptionE HTTP error response: Bad Request. Reason: HTTP Status 400 – Bad Requestbody font-family:Tahoma,Arial,sans-serif; h1, h2, h3, b color:white;background-color:#525D76; h1 font-size:22px; h2 font-size:16px; h3 font-size:14px; p font-size:12px; a color:black; .line height:1px;background-color:#525D76;border:none;

HTTP Status 400 – Bad Request

[context]zKq7AVECAAQAAEnuTgEJdm13YXJlLWRyAADtoRxsaWJ2bWFjb3JlLnNvAAGkghBsaWJjb25uZWN0aW9uLWJhc2Uuc28AARm6EAEacAoATQExAK0YMQAOJUECh38AbGlicHRocmVhZC5zby4wAAMvNg9saWJjLnNvLjYA[/context] [backtrace begin] product: VMware vCenter Site Recovery Manager, version: 8.7.0, build: build-21950025, tag: vmware-dr, cpu: x86_64, os: linux, buildType: release backtrace[03] libvmacore.so[0x001CA1ED] backtrace[04] libconnection-base.so[0x001082A4] backtrace[05] libconnection-base.so[0x0010BA19] backtrace[06] libconnection-base.so[0x000A701A] backtrace[07] libvmacore.so[0x0031014D] backtrace[08] libvmacore.so[0x003118AD] backtrace[09] libvmacore.so[0x0041250E] backtrace[10] libpthread.so.0[0x00007F87] backtrace[11] libc.so.6[0x000F362F] [backtrace end]

 



Environment

VMware Site Recovery Manager 8.x
VMware vSphere Replication 8.x

Cause

Site Recovery Manager is not able to resolve Vsphere Replication FQDN.

Resolution

See workaround.

Workaround:
Login to the Vsphere Replication appliance: https://FQDN:5480
Change local host in reconfigure in vSphere Replication from FQDN to IP.
image.png
Perform the above step on other site.
Reconnect in site recovery
Everything should be synched afterward.

Additional Information

Impact/Risks:
Cannot configure VM protection in Site Recovery Manager.

 
Alternate solution:
 
If the IP address settings shown above cannot be used due to security reason by the customer then the local host name and the certificate need to be set using lowercase only for the FQDN of the VRMS appliance:
 
Example : use vrms1.domain.com instead of VRMS1.domain.com