Accessing the VAMI (https://VCSA:5480) stuck on "Getting Started"/"Setup vCenter" page
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Accessing the VAMI (https://VCSA:5480) stuck on "Getting Started"/"Setup vCenter" page

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Article ID: 323190

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • No login page is displayed when opening the vCenter Server Appliance VAMI UI (https://vcenter-fdqn:5480) in a web browser.
  • Instead, you see a "Getting Started" page with a yellow banner saying "vCenter Server has been restored. However, additional steps must be completed before it is available for use. Click the link below to continue.", similar to the image below:



 

  • vCenter is otherwise functioning as expected.

  • When looking in /var/log/vmware/applmgmt/vami.log you may find the following entries:

 

Cause

This issue can occur when there are stale reconciliation files present in /storage/applmgmt/backup_restore/ and /etc/vmware/, such as:

  • /storage/applmgmt/backup_restore/restoreReconciliation-history.json
  • /storage/applmgmt/backup_restore/backup-history.json
  • /etc/vmware/backupMarker.txt

Can also occur when the following contents are observed in /dev/shm/backupRestore.json:

{
    "failingServiceState": [],
    "Pid": 50196,
    "serviceStartMonoSec": null,
    "backupSize": 0,
    "startTS": "###########",
    "version": "###########",
    "duration": 0,
    "dirCreated": false,
    "initialZestimatedTime": 0,
    "replicationPartners": [],
    "jobType": "MANUAL",
    "progress": 30,
    "estimatedSize": 0,
    "build": "###########",
    "message": [
        {
            "id": "com.vmware.applmgmt.reconciliation.general_error",
            "args": [
                "<vCenter hostname here>"
            ],
            "defaultMessage": "An error occurred during reconciliation operation. See logs for details. https://<vCenter hostname here>/appliance/support-bundle"
        }
    ],
    "state": "FAILED",
    "request": {},
    "startMonoSec": 3710,
    "endTS": "###########",
    "Id": "###########",
    "product": "###########",
    "operation": "RECONCILIATION"
}

Resolution

  1. Stop the application management service:
    # service-control --stop applmgmt
  2. Move the stale reconciliation files out of the folder into another location, e.g. /tmp/:
    # mv /storage/applmgmt/backup_restore/restoreReconciliation-history.json /tmp
    # mv /storage/applmgmt/backup_restore/backup-history.json /tmp
    # mv /etc/vmware/backupMarker.txt /tmp
    
  1. If necessary, modify /dev/shm/backupRestore.json and change "FAILED" to "SUCCEEDED" and remove the message field (modify only the highlighted fields):
    1. Old contents:

      {
          "failingServiceState": [],
          "Pid": 50196,
          "serviceStartMonoSec": null,
          "backupSize": 0,
          "startTS": "###########",
          "version": "###########",
          "duration": 0,
          "dirCreated": false,
          "initialZestimatedTime": 0,
          "replicationPartners": [],
          "jobType": "MANUAL",
          "progress": 30,
          "estimatedSize": 0,
          "build": "###########",
          "message": [
              {
                  "id": "com.vmware.applmgmt.reconciliation.general_error",
                  "args": [
                      "<vCenter hostname here>"
                  ],
                  "defaultMessage": "An error occurred during reconciliation operation. See logs for details. https://<vCenter hostname here>/appliance/support-bundle"
              }
          ],
          "state": "FAILED",
          "request": {},
          "startMonoSec": 3710,
          "endTS": "###########",
          "Id": "###########",
          "product": "###########",
          "operation": "RECONCILIATION"
      }

      New contents:

      {
          "failingServiceState": [],
          "Pid": 50196,
          "serviceStartMonoSec": null,
          "backupSize": 0,
          "startTS": "###########",
          "version": "###########",
          "duration": 0,
          "dirCreated": false,
          "initialZestimatedTime": 0,
          "replicationPartners": [],
          "jobType": "MANUAL",
          "progress": 30,
          "estimatedSize": 0,
          "build": "###########",
          "message": [],
          "state": "SUCCEEDED",
          "request": {},
          "startMonoSec": 3710,
          "endTS": "###########",
          "Id": "###########",
          "product": "###########",
          "operation": "RECONCILIATION"
      }

  2. Restart the applmgmt service:
    #service-control --start applmgmt
    Note: In some situations, the VAMI UI might still be showing an error message, such as in the screenshot below. Should you experience this issue, please reboot the vCenter Server Appliance:
  1. Verify that login to the VAMI UI is possible again.