vAPI-Endpoint service health shows as Yellow in VAMI UI of vCenter Server Appliance 7.0
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vAPI-Endpoint service health shows as Yellow in VAMI UI of vCenter Server Appliance 7.0

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Article ID: 322790

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • In the VAMI UI, the health status of vAPI-Endpoint service shows as "Healthy with warnings". The description of the status states: "Failed to connect to [uuid]\com.vmware.vcenter.nsxd.vapi vAPI provider"
  • In log file /var/log/vmware/vapi/endpoint/endpoint.log you see entries similar to:
2020-07-31T17:24:42.793Z | WARN  | state-manager1            | ApiInterfacesFactory           | Retrieving interfaces for service 8a17038f-65
2020-07-31T17:24:42.801Z | WARN  | state-manager1            | ApiInterfacesFactory           | The cache does not contain entry for service 8a17038f-6504-4830-ac6b-c7e9be79a98e\com.vmware.vcenter.nsxd.vapi. The interfaces will be skipped.
2020-07-31T17:24:42.802Z | INFO  | state-manager1            | HealthStatusCollectorImpl      | HEALTH YELLOW Failed to connect to 8a17038f-6504-4830-ac6b-c7e9be79a98e\com.vmware.vcenter.nsxd.vapi vAPI provider.
2020-07-31T17:24:42.893Z | INFO  | state-manager1            | DefaultStateManager            | Invoking vcenter-shim-service-builder
 
Note: The preceding log excerpts are only examples. Date, time and environmental variables may vary depending on your environment.


Environment

VMware vSphere 7.0.x

Cause

The vapi-endpoint service sees that there is the registration in Lookup Service and tries to connect to http://localhost:8920.nsxd which returns 404 page not found. This error sets the health status of the service to yellow because it does not have connection to one of its vapi providers.

Resolution

This issue is resolved in vCenter Server 7.0 Update 1, available at VMware Downloads.

Workaround:
This Warning message can be safely ignored, if immediate upgrade to vCenter Server 7.0 U1 is not possible.

Note:

vCenter versions newer than 7.0 Update 1 can still show similar VAPI endpoint health status messages as described in this article.

They are benign when happening during a reboot.

Due to the order in which the vCenter services are stopped for a reboot, VAPI might still be trying to connect to a service that has already been stopped. VAPI endpoint health alarms triggered during or right after a vCenter reboot are therefore benign and can be ignored.

If you are running a vCenter version newer than 7.0 Update 1 and are receiving VAPI endpoint health alarms without having recently rebooted the vCenter Server, please reach out to the VMware support by opening a support case.

Additional Information