VMware Cloud Foundation Usage Meter is not uploading product usage data to VCF Business Services console
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VMware Cloud Foundation Usage Meter is not uploading product usage data to VCF Business Services console

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Article ID: 322769

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Updated On: 06-11-2025

Products

VMware Usage Meter

Issue/Introduction

Symptoms:

VMware Cloud Foundation Usage Meter appliance is not uploading any data to VCF Business Services console.

Environment

VMware vCloud Usage Meter 4.8
VMware Cloud Foundation Usage Meter 9.0
 

Cause

This issue occurs if the VMware Cloud Foundation Usage Meter

  • version is not supported.
  • is not registered.
  • does not have a valid access token.
  • has connectivity issues with the VCF Business Services console.

Resolution

To resolve this issue

  1. Ensure that VMware Cloud Foundation Usage Meter version is 9.0 or greater.

    1. Please follow these instructions for usage meter upgrade https://techdocs.broadcom.com/bin/gethidpage?ux-context-string=um-004&appid=um9-0&language=&format=rendered 

  2. Ensure that VMware Cloud Foundation Usage Meter is registered.

    1. Please follow these instructions for registering https://techdocs.broadcom.com/us/en/vmware-cis/vcf/usage-meter/9-0/vcf-usage-meter-deployment-and-administration-guide/managing-vcf-usage-meter-usage/register-a-vcf-usage-meter-instance.html

  3. Ensure that VMware Cloud Foundation Usage Meter has a valid access token.

    1. Please follow these instructions for generating/rotating access token https://techdocs.broadcom.com/us/en/vmware-cis/vcf/usage-meter/9-0/vcf-usage-meter-deployment-and-administration-guide/managing-vcf-usage-meter-usage/regenerate-an-access-token-in-the-vcf-business-services-console.html
       
  4. Ensure proper connectivity from VMware Cloud Foundation Usage Meter to VCF Business Services console > Usage Management.
    1. VMware Cloud Foundation Usage Meter must be connected to the Internet, and all supported VMware products that can be metered must have their ports open so that the appliance can connect to them. See for reference the ports of the VMware products that need to be open for VMware Cloud Foundation Usage Meter https://ports.broadcom.com/home/vCloud-Usage-Meter
  1. Remediate VCF Business Services console connectivity problems.

    1. Enable SSH access to the VMware Cloud Foundation Usage Meter by entering the following command  in the VMware Cloud Foundation Usage Meter (Web or Remote) Console as root.

      service sshd start

    2. Log in to VMware Cloud Foundation Usage Meter via SSH as usagemeter.

      ssh usagemeter@<usage-meter-address>

    3. The VMware Cloud Foundation Usage Meter address could be its IP address or Fully Qualified Domain Name (FQDN). Test connectivity to VCF Business Services console > Usage Management by using the openssl command depending on the proxy usage.

      1. openssl command when using a direct connection to VCF Business Services console > Usage Management.

        openssl s_client -connect eapi.broadcom.com:443

      2. openssl command when using proxy to connect to VCF Business Services console > Usage Management.

        openssl s_client -connect eapi.broadcom.com:443 -proxy <proxy-address>:<proxy-port>

        The proxy server address could be its IP address or Fully Qualified Domain Name (FQDN).

      3. You should receive the following response at the end of the output by openssl command.

        "Verify return code: 0 (ok)"

    4. Log in to VCF Business Services console > Usage Management and check the VMware Cloud Foundation Usage Meter upload status. Next to the VMware Cloud Foundation Usage Meter name, under Status, you will also find information for the latest successful upload made from the appliance to VCF Business Services console > Usage Management.

    5. Check the Notifications tab in the VMware Cloud Foundation Usage Meter web interface for specific details related to the detected missing uploads.

    6. Manually verify if usage data can be uploaded to VCF Business Services console > Usage Management.

      1. Log in to the web interface of your VMware Cloud Foundation Usage Meter and navigate to the Settings tab, Cloud Connectivity menu. Click Test Connection. The returned notification should be "All Data Sent Successfully".

    7. Check if archive data is uploaded or not. Go to the VMware Cloud Foundation Usage Meter archive folder and check if .info & .zip folders are present in the archive folders like collection/notification. In case those folders are not present, contact VMware support to investigate the issue.

Examples for VMware Cloud Foundation Usage Meter 9.0:

  • Notification folder

ls -l /opt/vmware/umdata/Notification/2025/22/02/

  • Collection folder

    ls -l /opt/vmware/umdata/UM_Collection/2025/22/02/

In case another response is returned, contact VMware support to investigate the issue.