Collection error appears after adding VMware Aria Operations for Networks (formerly vRealize Network Insight) to vCloud Usage Meter
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Collection error appears after adding VMware Aria Operations for Networks (formerly vRealize Network Insight) to vCloud Usage Meter

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Article ID: 322761

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

Symptoms:
The following vRNI collection errors are shown after checking the collection-vrni-error.log located at /opt/vmware/cloudusagemetering/platform/log.

[2021-06-24 06:26:53]  | ERROR | RNI collector thread | com.vmware.um.collector.CollectionHelper | VRNI collector1560 | Collection error HTTP POST api/ni/entities/fetch on server xfailed with: timeout=>timeout=>Socket closed=>Socket closed

[2021-06-24 06:26:53]  | ERROR | RNI collector thread | com.vmware.um.collector.CollectionHelper | VRNI collector1560 | Status (COLLECT_API_ERR) for VRNI server 11: Collection error: APIError


Environment

VMware vCloud Usage Meter 4.8

Cause

This is due to a socket getting closed during an API request sent to the vRNI server.

Resolution

Procedure

To solve this issue, do the following:

  1. Take a snapshot of your Usage Meter appliance.
  2. Go to the below directory:
cd /opt/vmware/cloudusagemetering/platform/conf/schedule-executions/collection.yml
  1. Take a backup of the collection.yml file by running the command:
cp collection.yml collection.yml.bak
  1. Check the content of the collection.yml file by entering:
vi collection.yml
  1. Add the following keys for product - vrni.
    httpConnectionTimeout
    httpWriteTimeout
    httpReadTimeout

    eg:

    httpConnectionTimeout 300
    httpWriteTimeout 300
    httpReadTimeout 300
  2. Exit the vi editor by pressing the Escape key and then entering :wq! (save and exit ). If you want to exit the vi editor without making any changes, enter :q.
  3. Reboot the appliance from the vCenter.
  4. Edit the vRNI credentials in the Usage Meter web application. Click Save. An OK status will show that the vRNI collection is now started.
Note: Restarting services using the root account is not recommended. You need to reboot your Usage Meter appliance instead.