Data upload to vCloud Usage Insight fails intermittently
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Data upload to vCloud Usage Insight fails intermittently

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Article ID: 322746

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
Upload to vCloud Usage Insight fails intermittently with notification and collection errors. A connection test from vCloud Usage Meter to vCloud Usage Insight as per KB article 82023 works fine.

However, the following HTTPS connectivity check to vCloud Usage Insight
openssl s_client -connect ums.cloud.vmware.com:443 -servername ums.cloud.vmware.com  

throws this error:

getaddrinfo: Name or service not known
connect:errno=0


Environment

VMware vCloud Usage Meter 4.x

Cause

The cause for this issue is that multiple DNS servers are used, leading to the ums.cloud.vmware.com address not being resolved.

Resolution

Update /etc/systemd/resolved.conf and remove any additional DNS entries.

Procedure

To solve the upload issue, do the following:
  1. SSH to the Usage Meter appliance as usagemeter.
  2. Switch to the root account:
sudo root
  1. Back up the resolved.conf  located at /etc/systemd  by running the command:
cp /etc/systemd/resolved.conf /etc/systemd/resolved.conf.bak
  1. Open the resolved.conf file.
vi resolved.conf
  1. Type to switch into insert mode and start editing the file.
  2. Modify the /etc/systemd/resolved.conf to remove the second DNS entry.
  3. Save your changes and exit the vi editor.
:wq!
Note: If you don't want to save your changes, enter :q! to exit the editor.
  1. Reboot the appliance.
reboot


Additional Information

If you are using a .local domain, it will be worth updating the Domains field in the resolved.conf file as per KB article 83945.