Generating a support bundle in VCF Usage Meter does not include archived logs
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Generating a support bundle in VCF Usage Meter does not include archived logs

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Article ID: 322736

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Upon trying to generate a support bundle for VCF Usage Meter appliance, it does not include all archived logs.

Environment

VCF Usage Meter 9.x

Cause

The script generates the support bundle only and does not include all archived logs.

Resolution

To generate a support bundle including all of the VCF Usage Meter logs, perform the following steps:

  1. Log in to VCF Usage Meter appliance as root.
  2. Enable SSH on the appliance.
service sshd start
Note: You can also enable SSH connection from the VCF Usage Meter web application, under Profile - > VAMI. Then, log in to VAMI as root and enable SSH under Access.
  1. Connect remotely to the appliance as usagemeter.
ssh usagemeter@um-appliance-ip
  1. Enter the usagemeter account password.
  2. Go to the directory where the script generating a support bundle is located.
    /opt/vmware/cloudusagemetering/platform/bin
  3. Edit the support bundle script:
vi bundle.sh
  1. Press i to enter in interactive mode.
  2. Remove the following line from the script under "Collecting platform data files".
/usr/bin/tar -uf bundle.tar platform/log/vmware-um-schedule* platform/log/collection-*.log &>/dev/null
  1. Add the following line instead to the script.
/usr/bin/tar -uf bundle.tar platform/log/vmware-um-schedule* platform/log/collection-* &>/dev/null
  1. Save the changes to the script by entering ESC and writing the following in the prompt.
    :wq!
  2. Run the saved script.
./bundle.sh
  1. The support bundle will be created, and saved under /opt/vmware/cloudusagemetering/.
  2. Exit the ssh connection.
exit
  1. Copy the support bundle to a local directory.
scp usagemeter@um-appliance-ip:/opt/vmware/cloudusagemetering/<bundle-name> <local-directory-path>
  1. Log in to the appliance as root.
  2. Stop the SSH connection to Usage Meter appliance.
service sshd stop
Note: You can also disable the SSH connection to the appliance from the Usage Meter web application, under Profile - > VAMI. Then, log in to VAMI as root and disable SSH under Access.




Additional Information

Impact/Risks: The missing logs from the generated support bundle may hold valuable information for the cause of VCF Usage Meter issue.

Generate Support Bundle Collections in VCF Usage Meter