NSX-T Edge is disconnected after restore from backup
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NSX-T Edge is disconnected after restore from backup

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Article ID: 322627

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Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
  • A restore has taken place of NSX Manager.
  • Edge Nodes show disconnected state in UI.
  • NSX manager will not be able to communicate with the edges which are already in "to version".
  • The user will not be able to do any update on this edge nodes and no status information of these edge transport nodes will be available.
  • /var/log/syslog on the Edge Node will display entries similar to:
2022-05-20T15:31:03.285Z localhost NSX 2251 - [nsx@6876 comp="nsx-edge" subcomp="nsx-proxy" s2comp="mpa-proxy-lib" tid="2251" level="INFO"] AphConnectionManager: ConnectionDown for endpoint ssl://192.168.10.213:1234 for reason network error

2022-05-20T15:58:13.989Z localhost NSX 2251 - [nsx@6876 comp="nsx-edge" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2487" level="ERROR" errorCode="RPC503"] RpcTransport[0]::RemoteService[b0b77af4-c59e-42e4-ae05-bc10ab18dca2] Failed to resolve service: 6-No such device or address


Environment

VMware NSX-T
VMware NSX-T Data Center 3.x
VMware NSX-T Data Center

Cause

The NSX Manager has been restored to an earlier version than that currently running on the Edges nodes.
The backup does not contain a whitelist entry for the later version Edges (this whitelisting task is completed by  the upgrade coordinator).

Resolution

This is a known issue affecting VMware NSX-T 3.x and later, currently there is no resolution.

Workaround:
Trigger the upgrade of the Edge component from the NSX Manager.