NSX-T Edge disconnected from managers after restoring NSX to an older version
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NSX-T Edge disconnected from managers after restoring NSX to an older version

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Article ID: 322627

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Updated On:

Products

VMware NSX

Issue/Introduction


  • A restore has taken place of NSX Manager.
  • Edge Nodes show disconnected state in UI.
  • NSX manager will not be able to communicate with the edges which are already in "Upgraded version".
  • The user will not be able to do any update on this edge nodes and no status information of these edge transport nodes will be available.
  • /var/log/syslog on the Edge Node will display entries similar to:
2022-05-20T15:31:03.285Z localhost NSX 2251 - [nsx@6876 comp="nsx-edge" subcomp="nsx-proxy" s2comp="mpa-proxy-lib" tid="2251" level="INFO"] AphConnectionManager: ConnectionDown for endpoint ssl://<IP-Address>:1234 for reason network error

2022-05-20T15:58:13.989Z localhost NSX 2251 - [nsx@6876 comp="nsx-edge" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2487" level="ERROR" errorCode="RPC503"] RpcTransport[0]::RemoteService[########-c59e-####-ae05-bc10ab18dca2] Failed to resolve service: 6-No such device or address


Environment

VMware NSX 
VMware NSX-T Data Center 3.x

Cause

The NSX Manager has been restored to an earlier version than that currently running on the Edges nodes.
The backup does not contain a whitelist entry for the later version Edges (this whitelisting task is completed by  the upgrade coordinator).

Resolution

This is a known issue affecting VMware NSX-T 3.x and later. The issue is resolved in NSX version 4.1.1 and above.

Workaround:
Trigger the upgrade of the Edge component from the NSX Manager.


If the above workaround does not resolve the issue. Please collect the following support bundles and open a case with Broadcom support.
1) NSX manager support bundle
2) Edge support bundles.

Please refer the below document for collecting the support bundle.
https://docs.vmware.com/en/VMware-NSX-T-Data-Center/3.2/administration/GUID-73D9AF0D-4000-4EF2-AC66-6572AD1A0B30.html

 

Additional Information

The issue may also occur when the API ceritificates have changed after restore. This is documented in KB https://knowledge.broadcom.com/external/article/369991