NSX-T upgrade fails with "NSX Manager upgrade dry run failed, Do not proceed with the upgrade."
book
Article ID: 322606
calendar_today
Updated On:
Products
VMware NSX Networking
Issue/Introduction
Symptoms:
You are upgrading to NSX-T 3.2.0 or higher.
Your NSX-T managers are small form factor appliances.
In the NSX-T UI the following message is displayed:
"NSX Manager upgrade dry run failed. Do not proceed with the upgrade. Please collect the support bundle and contact VMWare GS. Failed migrations: Extracting the required files from MP vmdk Starting parallel Corfu Migrating data 2023-03-23 07:31:42.560093 Error running logical data migration tool. return value 137, log file /var/log/proton/logical-migration.log Ending Manager dry-run script"
On the NSX-T manager the following log file is not present: /var/log/proton/logical-migration.log
In log file /var/log/upgrade-coordinator/upgrade-coordinator.log we see the same message:
2023-03-23 07:31:42.560093 Error running logical data migration tool. return value 137, log file /var/log/proton/logical-migration.log
Environment
VMware NSX-T Data Center VMware NSX-T Data Center 3.x
Cause
There are two issues here:
The message display with "return value 137" indicates that the Appliance is running low on memory. NSX-T manager in a production environment should be medium or large form factor, please refer to the following guide for further details NSX-T Installation Guide.
The dry run, referred to in the error is part of the pre checks carried out before an upgrade starts.
The path displayed in the error message is incorrect, since NSX-T 3.2.1 the location is now: /var/log/upgrade-coordinator/upgrade-coordinator.log
Resolution
This is a pre check and as such has warned of this issue before your upgrade has begun, that is you have not upgraded any components yet. Please increase the NSX-T manager appliance form factor to a supported size (medium or large) and then complete the upgrade. The issue with the wrong log location displayed in the error is resolved in NSX 4.x.
Workaround: If this is a lab or testing environment, then you can try restarting the NSX-T Manager appliance which is running the pre checks. Post reboot, the NSX-T manager should get enough free memory for the pre checks to complete. If this is not a small appliance and you encounter this issue, please open a support request and reference this KB.