NSX-T Critical alarm indicates: LB Edge Capacity In Use High
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NSX-T Critical alarm indicates: LB Edge Capacity In Use High

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Article ID: 322486

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When an NSX-T deployment utilizes Edge nodes (e.g., Large, Medium, or Small) with configured load balancer services, a critical alert may be observed within the NSX-T Manager UI. 
  • In the NSX-T manager UI under: Home, Alarms, a Critical alert is observed for:
    • Feature: LB Edge Capacity In Use High
    • Description: The usage of the load balancer service in Edge node ########-####-####-####-############ is high. The threshold is 80%.
    • Recommended Action: Deploy a new Edge node and move the load balancer service from existing Edge nodes to newly deployed Edge node.

Note: Above ########-####-####-####-############ represents the Edge node UUID where the load balancer is deployed.

Environment

VMware NSX-T Data Center
VMware NSX

Cause

The alarm threshold is set at 80%, so with the Edge node size and allowed load balancer size as per below table, the limit would always be breached at 100% and trigger the alarm:

Edge node size Credits Available Load balancer size Credits required per LB size
Small 1 Small  
Medium 10 Medium 10
Large 40 Large 40
XLarge 50 XLarge  


The Edge nodes can only have a specific size load balancer, this depends on the size of the load balancer and the Edge node.
See configuration the following page for details on number of load balancers allowed per Edge node and sizes allowed.
VMware Configuration Maximums for VMware NSX 4.2 Load Balancer.


Use the following API to check the load balancer usage per NSX-T Edge node:
GET https://<nsx-t-manager-ip>/api/v1/loadbalancer/usage-per-node/<edge-node-uuid>

Sample result:
{
  "form_factor": "MEDIUM_VIRTUAL_MACHINE",
  "edge_cluster_id": "########-####-####-############",
  "current_credit_number": 10, ----->>>>> This is the number of load balancer credits for a medium NSX-T edge node
  "remaining_credit_number": 0, ----->>>>>> This indicates remaining load balancer credits for this medium NSX-T edge node
  "usage_percentage": 100.0, ----->>>>>> This indicates usage is at 100%
  "severity": "RED",
  "current_pool_members": 0,
  "current_virtual_servers": 1,
  "current_pools": 0,
  "current_small_load_balancer_services": 0,
  "current_medium_load_balancer_services": 1,
  "current_large_load_balancer_services": 0,
  "current_xlarge_load_balancer_services": 0,
  "remaining_small_load_balancer_services": 0,
  "remaining_medium_load_balancer_services": 0,
  "remaining_large_load_balancer_services": 0,
  "remaining_xlarge_load_balancer_services": 0,
  "remaining_pool_members": 2000,
  "type": "LbEdgeNodeUsage",
  "node_id": "########-####-####-####-############"
}

Note: The documented configuration maximums may differ, depending on versions, please check for your version.

Resolution

Once these alarms are validated that the correct size load balancer is on the correct size Edge node, these alarms can be resolved.

Workaround:
Review the VMware Configuration Maximums and confirm the correct sizing is done per Edge node.

If there is a single LB instance (small/medium/large) in an NSX-T Edge Node of same size (small/medium/large); then deploy a new NSX-T Edge Node of a larger size and move the LB instance to that new Edge Node, this will provide extra capacity to add more load balancer instances, if required.

Note: In the case of an XLarge load balancer, only Bare-Metal Edge Nodes support multiple XLarge load balancers, therefore this workaround require Bare-Metal Edge Node in case of multiple XLarge load balancers.

Additional Information

For additional information in relation to the "Read load balancer usage for the given node" API, please see the LbEdgeNodeUsage in NSX REST API Guide: LbEdgeNodeUsage (schema) (Deprecated).

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • NSX Edge support bundles.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

Handling Log Bundles for offline review with Broadcom support