The NSX-T UI displays alarms indicating 'OSPF Neighbors Went Down'
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The NSX-T UI displays alarms indicating 'OSPF Neighbors Went Down'

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Article ID: 322464

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • You have NSX-T 3.1.1 or greater.
  • You are using OSPF routing and there is no dataplane impact.
  • You are receiving continuous alarms of "OSPF Neighbor went Down" in an Open state.
  • If you resolve the alarms, they appear again.
  • These alarms are not related to changes made on the environment such as re-election or configuration change on OSFP routers outside of NSX-T.


Environment

VMware NSX-T Data Center

Cause

Due to the nature of OSPF, as neighbors are not statically added, alarms can be generated when configuration changes occur outside of NSX-T control, such as configuration changes or re-election.
Under normal circumstances, when these alarms are triggered and it is known they are due to the above, the alarms can be resolved and should not re-appear again until a change occurs again.
In certain cases, the alarms may not be resolved and are persisted internally.

Resolution

This issue is resolved in NSX-T 4.0 available at VMware downloads.

Workaround:
To work around this issue, we will need to restart the RCPM (Routing Control Plane Manager) service on the edge node(s).
  • login to the Edge nodes using root credentials and run:
service nsx-edge-rcpm restart
  • Then once services have restarted, in the NSX-T UI mark the alarms as resolved.
Please note that this workaround is disruptive to production datapath so it is advisable to perform it in a scheduled maintenance window, the downtime is expected to be from 30 seconds to 1 minute.