Login to CSM (Cloud Services Manager) Appliance fails with error: Client certificate not found in trust store.
search cancel

Login to CSM (Cloud Services Manager) Appliance fails with error: Client certificate not found in trust store.

book

Article ID: 322420

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • NSX-T CSM appliance is deployed.
  • The version of NSX-T is 4.0.1 or lower.
  • After entering the username and password, then clicking 'LOG IN', you receive the following ERROR:
Internal server error has occurred.","details":" Client certificate not found in trust store","error_code":99
  • As can be seen in the following image:
  • Logging into the Unified Appliance (UA) does not encounter the same issue. The UA is the standard NSX-T manager appliance, not the CSM manager.


Environment

VMware NSX-T

Cause

There was an issue when populating the trusted CA configurations on the CSM managers.

Resolution

This issue is resolved in VMware NSX 4.0.1.1 available at VMware Downloads.

Workaround:
When the browser asks to select a certificate to continue logging onto the system, click cancel, instead of attempting to select a certificate.
Then proceed to login normally and you should not get presented with this message now.