Setting IPv4/IPv6 Configuration on vCenter Server Failed: "IP configuration not allowed"
search cancel

Setting IPv4/IPv6 Configuration on vCenter Server Failed: "IP configuration not allowed"

book

Article ID: 322370

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Updating management network configuration on VCSA VM

Symptoms:
vCenter fails to connect to network
ERR_CONNECTION_TIMED_OUT

Environment

VMware vCenter Server

Cause

When a VCSA VM is migrated and needs to update eth0 (management network) changes fail

Resolution

1. Login to the Host Client having the VCSA VM
2. Launch Remote console of VCSA VM
3. Alt+F1 to ssh the vCenter and login with root
4. /opt/vmware/share/vami/vami_config_net
5. Select option 0 to verify current configuration
6. Select option 2, 3, 4, and 6 update eth0 network settings
7. Update DNS zone with the right IP address
8. Reboot the vCenter to apply changes

 

If you are unable to update the configuration using the path /opt/vmware/share/vami/vami_config_net, follow the steps outlined below based on your specific scenario.

Important Note: Before proceeding with any of the actions above, it is recommended to take a backup copy of the .vmx file. This ensures you can restore the original configuration if needed.

 

Scenario 1: vCenter on a Distributed Virtual Switch (DVS)

  1. Migrate vCenter from DVS to a Standard Virtual Switch (VSS):

  2. If the Issue Persists:

    • Record the current IP configuration of the vCenter server.
    • Delete and recreate the vmxnet3 network adapter.
    • Once the vCenter reconnects, the IP configuration may automatically be restored from the .vmx file. If not, manually assign the IP configuration.

Scenario 2: vCenter on a Standard Virtual Switch (VSS) or Ephemeral Port Group

If the vCenter server is already on a VSS or an ephemeral port group and you encounter the following error when setting IP configuration:

VCSA- Setting ip/ipv6 configuration failed: ('IP configuration not allowed')
  • Record the current IP configuration.
  • Delete and recreate the vmxnet3 network adapter. 

 

Attachments

image001 get_app