Email alerts stop working after updating to vCenter Server Appliance 6.7.x.
search cancel

Email alerts stop working after updating to vCenter Server Appliance 6.7.x.

book

Article ID: 322352

calendar_today

Updated On:

Products

VMware vCenter Server 6.0

Issue/Introduction

Email alerts are not sent after patching vCenter server 6.7.x

We observe similar message in journalctl logs:

DATE HH:MM:SS HOSTNAME sendmail[100316]: 05DEuIHH067542: to=<[email protected]>, delay=4+22:47:54, xdelay=00:00:00, mailer=esmtp, pri=10202474, relay=domain.com., dsn=4.0.0, stat=Deferred: Connection timed out with domain.com.

It can be observed the relay address is not the one set on vCenter Server. If mail server is set to mailbox.domain.com, we see relay server address as domain.com.

Environment

VMware vCenter Server Appliance 6.7.x

Cause

After applying patch, relay server address is modified as domain.com instead of actual relay server address. Hence, vCenter resolves domain.com for relay server address and reaches one of the domain controllers' addresses instead of mail server causing the connection timed out message.

Resolution

Follow the below steps to re-configure SMTP configuration on the vCenter Server.

  1. Login to web client or H5 client to vCenter Server.
  2. Select the vCenter Server instance
  3. Navigate to Configuration > General and select Edit.
  4. Expand Mail configuration.
  5. Edit the Mail server to a different name other than the relay server address and click on Save.
  6. Edit the Mail server name again and set back to original name and save.
  7. Verify the email alerts are working