VSAN and/or VLCM views are missing in vSphere Client
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VSAN and/or VLCM views are missing in vSphere Client

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Article ID: 322342

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

The purpose of this article is to fix the missing views for vSAN, single image (VLCM), missing Lifecycle Manager from the main menu, Baselines, VMware Tools and VM Hardware from the Update Tab.

Symptoms:

  • vCenter is missing views on all clusters related to vSAN monitoring as well as anything other than "services" under "configuration". Views related to managing the clusters with a single image are also missing.
  • In /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log you find the following error message:
    [YYYY-MM-DDTHH:MM:SS] [ERROR] tp-nio-127.0.0.1-5090-exec-7 70000142 100008 200008 com.vmware.vise.mvc.controllers.PluginServiceController A general error occurred while evaluating plugin (com.vmware.vlcm.client:8.0.1.22088981:1467385155) dynamic extensions info from the vSphere Client platform. com.vmware.vapi.std.errors.Unauthorized: Unauthorized (com.vmware.vapi.std.errors.unauthorized) => {
        messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {
        id = vapi.security.authorization.invalid,
        defaultMessage = Unable to authorize user,
        args = [],
        params = <null>,
        localized = <null>
    }],
        data = <null>,
        errorType = UNAUTHORIZED



Environment

VMware vCenter Server 8.0.x

Cause

The reason for this is the 'administrators' group is missing from the 'SystemConfiguration.Administrators' group

Resolution

To solve this issue use the vSphere Client SSO administration page to re-add the 'administrators' group to the 'SystemConfiguration.Administrators' group:

  1. Login in vSphere Client using the default SSO administrator account ([email protected], the domain part might be different, depending on how you named the SSO domain)

  2. Change into Administration > Single Sign On > Users and Groups > Groups

  3. Find the SystemConfiguration.Administrators group and click on EDIT to add the Administrators back in it:

If the issue still persists, verify if the required plugins are loaded, by looking in Administration > Solutions > Client Plugins:

  • VMware vCenter Server Lifecycle Manager (remote)

  • VMware vSphere Lifecycle Manager Client (remote)

  • VMware vSphere Lifecycle Manager (local)

Should one or more of these plugins be missing, please reboot the VCSA. It is possible that it was not properly registered due to the administrators group missing previously.

After the reboot, open vSphere Client in a new browser tab and verify that the missing views are now visible. 

 

 

If you do not have access to the Single Sign On administration page, as a workaround:

  1. Select the VC where the issue is present

  2. Go in Administration > Solutions > Client Plugins

  3. Click on the VMware vSphere Lifecycle Manager Client (remote) plugin

  4. Click on the HIDE button and refresh the browser. This will revert the VLCM UI plugin from remote to local, and should work around the issue until the administrators group can be added correctly.