Compliance scan task for an ESXi host gets stuck at 30%
search cancel

Compliance scan task for an ESXi host gets stuck at 30%

book

Article ID: 322341

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When you run a compliance scan on an ESXi host through vSphere Lifecycle Manager, the scan task becomes stuck at 30% progress and fails to complete.

  • The vmware-vum-server.log shows entries similar to
    Error: boost::filesystem::file_size: No such file or directory: /storage/updatemgr/patch-store/hostupdate/vmw/metadata-###.zip

  • This prevents you from completing compliance checks and determining which patches or updates need to be applied to your ESXi hosts.

 

Environment

Seen in:

  • VMware vCenter Server 7.0.x

Cause

The "VMware vSphere Lifecycle Manager Check Notification" task has been deprecated from vCenter Server 7.0 release. But it may still remain in the database after upgrading from vCenter Server 6.7.

When the compliance scan attempts to reference the missing metadata file /storage/updatemgr/patch-store/hostupdate/vmw/metadata-###.zip" associated with this deprecated task, the scan fails because the file no longer exists in the expected location.

Resolution

Note: Take snapshot(s) and / or valid backups of the vCenter server(s) 

• service-control --stop vsphere-ui
• rm -rf /usr/lib/vmware-vsphere-ui/server/work/*
• rm -rf /storage/vsphere-ui/SerenityDB/serenity/*
• service-control --start vsphere-ui

Note: Take snapshot(s) and/or valid backups of the vCenter Server before proceeding.

1. Remove the deprecated scheduled task by following the steps in the article Failed or queued VMware vSphere Lifecycle Manager Check Notification tasks in vCenter Server 7.x 

2. Clear the vSphere UI cache:

  • Connect to the vCenter Server Appliance via SSH
  • Run: service-control --stop vsphere-ui
  • Run: rm -rf /usr/lib/vmware-vsphere-ui/server/work/*
  • Run: rm -rf /storage/vsphere-ui/SerenityDB/serenity/*
  • Run: service-control --start vsphere-ui

3. Reset the VUM database by following the steps in the article Resetting VMware Update Manager Database in vCenter Server Appliance 6.5/6.7/7.0/8.0

Additional Information

the impact or risks associated with this issue include:
  • Compliance scan check fails