Excessive logging consuming large space in syslog server during VM backup window
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Excessive logging consuming large space in syslog server during VM backup window

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Article ID: 322320

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
* Syslog server receives a very high number of events from the ESXi server during the backup window
* Sample events from vpxa log indicate NFC debug enabled logs 
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioRecvData: Srv receiving data, size = 44
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioServerProcessMain: Processing an operation
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioIoCB: Received callback
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioServerProcessMain: Processing an operation
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioIoCB: Received callback
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioServerProcessMain: Processing an IO callback
####-##-##T##:##:##.###Z info vpxa[2102103] [Originator@6876 sub=Libs] [NFC DEBUG] NfcAioSendMessage: Srv sending msg, opId = 4815839, type = 7, size = 44

* The /var/run/log/vmauthd.log on ESXi host points at the server requesting debug logging
####-##-##T##:##:##.###Z vmauthd[25040498]: Connect from remote socket (XX.XX.XX.XX:32938).
####-##-##T##:##:##.###Z vmauthd[25040498]: Connect from XX.XX.XX.XX
####-##-##T##:##:##.###Z vmauthd[25040498]: Received PROXY command for vpxa-nfc, session = 52 60 c7 5d 90 66 e4 9f-c7 41 9a 3c 9f d8 68 29
####-##-##T##:##:##.###Z vmauthd[25040498]: vmware-vpxa: Connected to vpxa-nfc-fd, remote end sent pid: 2100923

Environment

VMware vSphere ESXi 6.7

Cause

The issue is caused by the configuration in the Backup application requesting debug logging which is causing the log spew. 

The steps may vary from Backup vendor to vendor so please ask consult to consult their Backup Team/Vendor for precise steps. 

Resolution

Incase of Veritas the following file 'vixDiskLib.ini' is located at /usr/openv/lib/shared/vddk/lib64/

Sample file 

vixDiskLib.disklib.EnableCache = 0
vixDiskLib.nfc.LogLevel = 4
vixDiskLib.transport.LogLevel = 6
vixDiskLib.nfcFssrvr.timeoutMs = 0

The "vixDiskLib.nfc.LogLevel" needs to be set to 1 (error only) which should ensure the log spew is avoided. No service restart is needed on ESXi host but may need to check with the backup Vendor if the application would require restart for changes to be effective.