Error: downloading com.vmware.h4.vsphere.client
search cancel

Error: downloading com.vmware.h4.vsphere.client

book

Article ID: 322289

calendar_today

Updated On: 04-30-2025

Products

VMware vCenter Server 6.0 VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

You are receiving an error message that the plugin is failing to download the plugin com.vmware.h4.vsphere.client from vCenter



This cannot be rectified by removing the plugin in the vCenter MOB page as it is not listed as actionable there.
The actual commands apply to VCSA 7 only, slightly different paths are used for VCSA 6.7

Environment

6.0

7.0

8.0

Cause

This error seems to stem from one of the latest patch updates for vCenter Appliance.

 

Resolution

  1. Log in to the vCenter Server Appliance through SSH.

  2. Run this command to enable access to the Bash shell:

     shell.set --enabled true

    3. Type shell and press Enter.

    4.
Run this command to provide a list of running vSphere client plugins.

​​​​​​​​​​​​​​     /usr/lib/vmware-lookupsvc/tools/lstool.py list --ep-type com.vmware.cis.vsphereclient.plugin --url http://localhost:7090/lookupservice/sdk

       The output should be similar to this [edited for clarity]
       Note: The command will list all versions but only remove the one that is failing.

     /usr/lib/vmware-lookupsvc/tools/lstool.py list --ep-type com.vmware.cis.vsphereclient.plugin --url http://localhost:7090/lookupservice/sdk
        Service Product: com.vmware.h4
        Service Type: vsphere.client
        Service ID: 123x456x-zz7z-88y8-99y9-00y9b9y0999
        Site ID: default-first-site
        Node ID: x1x111x1xx11-22z2-y330-xxx444x
        Owner ID: vsphere-webclient-@vsphere.local
        Version: 0.4.1.0
        Endpoints:
                Type: com.vmware.cis.vsphereclient.plugin
                Protocol: http
                URL: [...]
                SSL trust:[...]

  1. Take note of the Service ID.
    In this example- Service ID: 123x456x-zz7z-88y8-99y9-00y9b9y0999

  2. Run this command, inserting the correct administrator@vsphere.local password.

     /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url http://localhost:7090/lookupservice/sdk --user administrator@vsphere.local --password ***** --id 123x456x-zz7z-88y8-99y9-00y9b9y0999 --no-check-cert

  1. Run the command to restart the service. 

     vmon-cli -r vsphere-ui 

  1. You will be logged out of the vSphere UI and will need to log in again. If the plug-in is successfully removed, the error should no longer occur.