"CloudVM SYSTEM HEALTH CHECK", vCenter Server Appliance Overall health Status shows Gray during Upgrade Precheck in SDDC-Manager
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Article ID: 322251
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
Symptoms:
- You are trying to upgrade a VCF (VMware Cloud Foundation) environment and upgrade pre-check fails during health check of vCenter Server Appliance
- Executing the command 'system.health.get' shows the status as gray on vCenter Server Appliance, sample screenshot pasted below :
- VCSA logs (/var/log/vmware/applmgmt.log) will show below error message
com.vmware.monitor.system not found in the health data
Note: This KB is applicable to VMware Cloud Foundation 4.1.x and 4.2.x versions.
Environment
VMware Cloud Foundation 4.1
VMware Cloud Foundation 4.2
VMware Cloud Foundation on VxRail 4.2
VMware Cloud Foundation on VxRail 4.1
Cause
This is caused due to a change in the APIs on vCenter Server, actual command to check the overall health of VCSA is "health.system.get"
Resolution
This issue is resolved in VMware Cloud Foundation 4.3.
Workaround:
Please follow below steps to workaround the issue :
- Check the health of vCenter Server Appliance using any of below methods
- Login to VCSA VAMI Page using URL "https://<VC FQDN / IP>:5480"
- Check the Health Status displayed in "Overall Health"
Sample Screenshot:
- If the Status shows "Good", ignore the VCF pre-check error and proceed with the upgrade
- Connect to VCSA using SSH (Eg. Putty)
- Execute the command "health.system.get" to check the VC Health Status
Sample Screenshot:
Note: In a VCF environment, default Appliance Shell should remain as "appliancesh", please do not change it.
- If the health shows green, ignore the VCF pre-check error and proceed with the upgrade
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