ESXi upgrades during a VMware Cloud Foundation 3.5 upgrade fail due to misidentified Intel Disks and Health Check for vSAN fails
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ESXi upgrades during a VMware Cloud Foundation 3.5 upgrade fail due to misidentified Intel Disks and Health Check for vSAN fails

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Article ID: 322218

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
  • When upgrading ESXi hosts to version 6.7 during a VMware Cloud foundation 3.5 uprade, the automation process fails for each host.
  • You see an error message that indicates there is a VSAN Health error.
  • The affected ESXi host is not able to get out of maintenance mode automatically and manual intervention is required.


Environment

VMware Cloud Foundation 3.0.x
VMware Cloud Foundation 3.5.x

Cause

Due to misidentified Vendor IDs on the disks a Health Check for vSAN failure occurs.  

Intel P4510 NVMe misidentified as Intel P4500 NVMe (56967) provides additional information related to this issue.
 
The following are the affected Intel P4510 device skus which have duplicate PCI IDs with P4500 
  • Intel® SSD DC P4510 Series SSDPE2KX010T8 (1.0 TB, 2.5” U.2) duplicated PCI IDs with
  • Intel® SSD DC P4500 Series SSDPE2KX010T7 (1.0 TB, 2.5" U.2)
  • Intel® SSD DC P4510 Series SSDPE2KX020T8 (2.0 TB, 2.5” U.2) duplicated PCI IDs with
  • Intel® SSD DC P4500 Series SSDPE2KX020T7 (2.0 TB, 2.5" U.2)
  • Intel   SSD DC P4500 Series SSDPE2KX040T7 (4.0 TB, 2.5-inch)

Resolution

This is a known issue affecting VMware Cloud Foundation. There is currently no resolution.

Workaround:
Use the following steps to workaround this issue:
  1. In the HTML5 Client, select the affected cluster.
  2. Navigate to Monitor-->vSAN-->Health-->Hardware compatibility-->Controller driver is VMware certified.
  3. Click the Silence Alert link.
  4. Manually take the affected hosts out of Maintenance Mode.


Additional Information

Intel P4510 NVMe misidentified as Intel P4500 NVMe (56967)