SDDC Manager UI under update/patches shows Error "NSX version not found for domain id: xxxx-xxx-xxxx-xxxx-xxxxxxxx nsxversion: null nsxtversion: null"
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SDDC Manager UI under update/patches shows Error "NSX version not found for domain id: xxxx-xxx-xxxx-xxxx-xxxxxxxx nsxversion: null nsxtversion: null"

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Article ID: 322190

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
 

  • In /var/log/vmware/vcf/sddc-manager-ui-app, messages similar to the below are seen
2019-08-16T03:16:28.301Z ERROR [eb30d59e01db4c64] [services/errorHandling.js, http-get-upgrade-status, productionErrorRoute:85] Sending error response:  {"upn":"[email protected]","id":"########-####-####-####-########55dd","requestedPath":"/ui/api/internal/lcm/upgradeStatus","error":{"name":"StatusCodeError","statusCode":500,"message":"Unable to retrieve aggregated domains upgrade status; Encountered fetching http://127.0.0.1/lcm/inventory/upgrades api; 500 - \"{\\n  \\\"status\\\": 500,\\n  \\\"code\\\": \\\"Internal Server Error\\\",\\n  \\\"message\\\": \\\"NSX version not found for domain id: ########-####-####-####-########ca0e nsxversion: null nsxtversion: null\\\"\\n}\"","error":"{\n  \"status\": 500,\n  \"code\": \"Internal Server Error\",\n  \"message\": \"NSX version not found for domain id: ########-####-####-####-########ca0e nsxversion: null nsxtversion: null\"\n}","options":

 

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware Cloud Foundation 3.8.x

Cause

This error appears when there is a communication issue between vCenter and NSX.

Resolution

The below information outlines troubleshooting steps that can be used to rule out different situation that may cause communication issues between vCenter and NSX
  • Verify that NTP is configured and in sync between both/ all appliances
  • Verify that DNS is configured correctly on the vCenter Server, the ESXi hosts and NSX Manager. Ensure that forward and reverse DNS resolution from vCenter Server, ESXi hosts, NSX Manager.
  • Check the NSX manager to see all services are running.
  • Verify that vCenter server vpxd process is listening on TCP port 8089. NSX Manager only support the default port 8089.
  • Verify that all ports required for NSX for vSphere 6.x are not blocked by a firewall. For related information, see Network Port Requirements for VMware NSX for vSphere (2079386)
  • Verify that the vCenter Server Managed IP Address is configured correctly.
  • If non-default ports are specified during a vCenter Server deployment, ensure that these ports are not being blocked by the ESXi host firewall.
  • Go to Network and Security > Installation and upgrade > Host preparation > Select a NSX Manager
    • Check if the associated NSX Manager is listed in VC 
    • Confirm EAM service Status
    • Confirm whether all the other feature such Firewall, VXLAN and communication channel are Enabled/Configured/Up. 
  • Check in vCenter MOB and confirm whether NSX manager version correctly reported.
  • Restart the EAM service
    •    service-control --stop vmware-eam
    •    service-control --start vmware-eam​​​​
  • Re-Register associated NSX manager 
    •  Login to NSX manager --> Manage vCenter Registration 
      • Update the Lookup service url with PSC FQDN with its credentials
      • Update the vCenter server FQDN and credentials 
    • Once it shows connected, Log out and login back to the vCenter web client