The vCenter Server upgrade from version 7.0 to 8.0 fails at 39% with the error: "Upgrade phase timed out" after getting stuck during the "Exporting the VMware Analytics Service data" step.
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Article ID: 322053
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
Symptoms:
During Stage 2 of the upgrade process, the task "Exporting VMware Analytics Service data" gets stuck at 39%.
Upgrade then fails with the below error:
Upgrade phase timed out. The time planned for the upgrade phase was 60 minutes. The upgrade phase has already been running for 60 minutes. To extend the default timeout, set environment variable UPGRADE_EXPORT_TIMEOUT
Environment
VMware vCenter Server 7.x VMware vCenter Server 8.x
Cause
This issue occurs because the push telemetry process sends an excessive number of requests with unique IDs, resulting in the creation of a large number of files in the "/var/log/vmware/analytics/prod" directory. In some cases, this has led to the accumulation of 185,000 to 375,000 files.
Resolution
Connect to the source vCenter server via SSH
Run the following command to check the number of files created on the vCenter server due to push telemetry process: ls /var/log/vmware/analytics/prod | wc -l
Download the cleaning_vddk_script.shscript from the attachments section of the KB.
Upload the script to vCenter and assign "execute" permissions with this command: chmod +x cleaning_vddk_script.sh
Run the script: ./cleaning_vddk_script.sh
Restart vCenter upgrade.
Note: By default, the script will apply changes to files older than 180 days. You can however pass a parameter to the script in order to use a different value (Example: 90 days). ./cleaning_vddk_script.sh 90