Some VLANs not showing in NSX-T bridge summary
search cancel

Some VLANs not showing in NSX-T bridge summary

book

Article ID: 322037

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Traffic is being dropped on some vlans on an edge bridge.
  • Login to the Edge node as user root, and verify the log /var/log/syslog.log, to see messages similar to the below indicating that two bridge endpoints with duplicate vlan ids are being pushed to the edge node:
<edge-name> NSX #### SWITCHING [nsx@####comp="nsx-edge" subcomp="datapathd" s2comp="lswitch" tname="##-####" level="WARN"] lswitch <uuid> is also using VLAN ####on device <switch name>
<edge-name> NSX ### FABRIC [nsx@####comp="nsx-edge" subcomp="datapathd" s2comp="dpc-pb" tname="##-####" level="ERROR" errorCode="EDG0400171"] dpc_create_vlan_lswitch failed to create lswitch <uuid>

 

Environment

VMware NSX

Cause

  • When 2 bridge endpoints associated with 2 separate overlay segments tries to get associated with the same bridge/edge nodes (they may use same bridge-profile or may use different bridge profiles but both of them are associated with the same edge cluster) using the same VLAN ID
  • Therefore, when such configuration is pushed to an edge node, the edge node cannot process any subsequent configuration changes in the edge bridge profile.

Resolution

Workaround:
Create a bridge profile and move all segments (except those with duplicate VLANs) from the existing bridge profile to the new bridge profile.

Additional Information

NOTE: To prevent such configuration to be pushed and realized on the edge nodes, a validation workflow has been introduced from 3.2.2 onwards which will throw an error on that specific segment and the segment will be in 'Failed' state on the NSX-T Manager UI when such configuration are made to a segment.
This will prevent such configuration to be pushed and get realized on the edge nodes.

Example error will be as below:
'There already exists a BridgeEndpoint on same edgeNodes [TransportNode/#############] with same vlan-transportzone PolicyTransportZone/############# and vlanId ####'